diff mbox series

[bug#56819,2/2] gnu: Add r-infercnv.

Message ID 20220728213859.21641-2-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#56819,1/2] gnu: Add r-phyclust. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu July 28, 2022, 9:38 p.m. UTC
* gnu/packages/bioconductor.scm (r-infercnv): New variable.
---
 gnu/packages/bioconductor.scm | 60 +++++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)

Comments

Ricardo Wurmus Aug. 1, 2022, 2:20 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioconductor.scm (r-infercnv): New variable.
[…]
> +           r-phyclust

This variable is not defined anywhere, or maybe I just can’t find it.
Ricardo Wurmus Aug. 2, 2022, 8:23 a.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:
>
>> * gnu/packages/bioconductor.scm (r-infercnv): New variable.
> […]
>> +           r-phyclust
>
> This variable is not defined anywhere, or maybe I just can’t find it.

The problem was that I only received the second email; the first one
wasn’t cc’d to me.  I then saw that the first patch is right there on
issues.guix.gnu.org, so I applied them both.

Sorry for the confusion!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 31484799b2..e9bfbed9b5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -49,6 +49,7 @@  (define-module (gnu packages bioconductor)
   #:use-module (gnu packages image)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages netpbm)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages statistics)
@@ -2647,6 +2648,65 @@  (define-public r-ideoviz
 arbitrary genomic intervals along chromosomal ideogram.")
     (license license:gpl2)))
 
+(define-public r-infercnv
+  (package
+    (name "r-infercnv")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "infercnv" version))
+       (sha256
+        (base32
+         "01f021fdxm058733rky46dlvqg7dmf5mn5x9lnq0fspp5665w3bl"))))
+    (properties `((upstream-name . "infercnv")))
+    (build-system r-build-system)
+    (inputs (list python))
+    (propagated-inputs
+     (list r-ape
+           r-argparse
+           r-biocgenerics
+           r-catools
+           r-coda
+           r-coin
+           r-digest
+           r-doparallel
+           r-dplyr
+           r-edger
+           r-fastcluster
+           r-fitdistrplus
+           r-foreach
+           r-futile-logger
+           r-future
+           r-ggplot2
+           r-gplots
+           r-gridextra
+           r-hiddenmarkov
+           r-leiden
+           r-matrix
+           r-paralleldist
+           r-phyclust
+           r-rann
+           r-rcolorbrewer
+           r-reshape
+           r-rjags
+           r-singlecellexperiment
+           r-summarizedexperiment
+           r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/broadinstitute/inferCNV/wiki")
+    (synopsis "Infer copy number variation from single-cell RNA-Seq data")
+    (description
+     "@code{InferCNV} is used to explore tumor single cell RNA-Seq data to identify
+evidence for somatic large-scale chromosomal copy number alterations, such as gains
+or deletions of entire chromosomes or large segments of chromosomes.  This is done
+by exploring expression intensity of genes across positions of a tumor genome in
+comparison to a set of reference \"normal\" cells.  A heatmap is generated
+illustrating the relative expression intensities across each chromosome, and it
+often becomes readily apparent as to which regions of the tumor genome are
+over-abundant or less-abundant as compared to that of normal cells.")
+    (license license:bsd-3)))
+
 (define-public r-iranges
   (package
     (name "r-iranges")