From 677c2cb792dde411f57e7ea9b3a20f1a1d35310d Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@disroot.org>
Date: Wed, 20 Jul 2022 11:25:31 -0400
Subject: [PATCH] gnu: sshfs: Update to 3.7.3.
* gnu/packages/linux.scm (sshfs): Update to 3.7.3.
[build-system]: Replace gnu-build-system with cmake-build-system.
[arguments]: Replace 'check with call to pytest.
[native-inputs]: Add dependencies to generate man page and run tests.
---
gnu/packages/linux.scm | 26 ++++++++++++++++++++------
1 file changed, 20 insertions(+), 6 deletions(-)
@@ -3472,20 +3472,34 @@ (define-public unionfs-fuse/static
(define-public sshfs
(package
(name "sshfs")
- (version "2.10")
+ (version "3.7.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libfuse/sshfs/releases/"
"download/sshfs-" version "/sshfs-" version
- ".tar.gz"))
+ ".tar.xz"))
(sha256
(base32
- "00fir2iykdx11g8nv5gijg0zjrp2g3ldypnv0yi6lq3h5pg5v13h"))))
- (build-system gnu-build-system)
+ "169fkilv060afgp9h7hvsbkg02bd1y77kmx06x0s7q1cvmxww62j"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python3" "-m" "pytest" "test/"))))))) ;; one test is skipped, fuse kernel module is not loaded
(inputs
- (list fuse glib))
+ (list fuse-3 glib))
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ python-docutils ;; man page
+ ;; tests
+ which
+ python
+ python-pytest
+ fuse))
(home-page "https://github.com/libfuse/sshfs")
(synopsis "Mount remote file systems over SSH")
(description
base-commit: be7b314f3fe22273e935accac22f313e44d3d970
--
2.37.1