diff mbox series

[bug#56771,26/33] gnu: Add qtnetworkauth, version 6.3.1.

Message ID 20220725230803.10002-26-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Maxim Cournoyer July 25, 2022, 11:07 p.m. UTC
* gnu/packages/qt.scm (qtnetworkauth): New variable.
---
 gnu/packages/qt.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9bd276ac33..121ff8b4fe 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1983,6 +1983,26 @@  (define-public qtnetworkauth-5
     (description "The Qt Network Authorization module provides an
 implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
 
+(define-public qtnetworkauth
+  (package
+    (name "qtnetworkauth")
+    (version "6.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (qt5-urls name version))
+              (sha256
+               (base32
+                "0apvsb2ip1m3kw8vi9spvf6f6q72ys8vr40rpyysi7shsjwm83yn"))))
+    (build-system cmake-build-system)
+    (arguments (list #:configure-flags #~(list "-DQT_BUILD_TESTS=ON")))
+    (native-inputs (list perl))
+    (inputs (list qtbase))
+    (home-page (package-home-page qtbase))
+    (synopsis "Qt Network Authorization module")
+    (description "The Qt Network Authorization module provides an
+implementation of OAuth and OAuth2 authenticathon methods for Qt.")
+    (license (package-license qtbase))))
+
 (define-public qtremoteobjects
   (package (inherit qtsvg-5)
     (name "qtremoteobjects")