@@ -5139,7 +5139,7 @@ (define-public lpsolve
(define trilinos-for-dealii-openmpi
(package
(name "trilinos-for-dealii-openmpi")
- (version "12.18.1")
+ (version "13.4.0")
(source
(origin
(method git-fetch)
@@ -5150,31 +5150,28 @@ (define trilinos-for-dealii-openmpi
(string-replace-substring version "." "-")))))
(file-name (git-file-name "trilinos" version))
(sha256
- (base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))))
+ (base32 "11vkn86dbvyvsf3zipd65y2f8vg5if9n3k7h3i8ybj95d4ck5r2n"))))
(build-system cmake-build-system)
(native-inputs
- (list
- ;; The build fails with the current gcc.
- ;; Use the version from when Trilinos was added.
- gcc-7
- gfortran
- ;; Trilinos's repository contains several C-shell scripts, but adding
- ;; tcsh to the native inputs does not result in the check phase running
- ;; any more tests than without it (nor is tcsh required to build
- ;; Trilinos).
- ;; It seems that Trilinos has replaced its use of C-shell test scripts
- ;; with CMake's testing facilities.
- ;; For example,
- ;; packages/zoltan/doc/Zoltan_html/dev_html/dev_test_script.html [1]
- ;; states that Zoltan's C-shell test script
- ;; packages/zoltan/test/test_zoltan has been obsoleted by the tests now
- ;; performed through CMake.
- ;;
- ;; Perl is required for some Zoltan tests and Python 2 for one ML test.
- ;;
- ;; [1]: https://cs.sandia.gov/zoltan/dev_html/dev_test_script.html
- perl
- python-2))
+ (list gfortran
+ ;; Trilinos's repository contains several C-shell scripts, but
+ ;; adding tcsh to the native inputs does not result in the check
+ ;; phase running any more tests than without it (nor is tcsh
+ ;; required to build Trilinos).
+ ;; It seems that Trilinos has replaced its use of C-shell test
+ ;; scripts with CMake's testing facilities.
+ ;; For example,
+ ;; packages/zoltan/doc/Zoltan_html/dev_html/dev_test_script.html [1]
+ ;; states that Zoltan's C-shell test script
+ ;; packages/zoltan/test/test_zoltan has been obsoleted by the tests
+ ;; now performed through CMake.
+ ;;
+ ;; Perl is required for some Zoltan tests and Python 2 for one ML
+ ;; test.
+ ;;
+ ;; [1]: https://cs.sandia.gov/zoltan/dev_html/dev_test_script.html
+ perl
+ python-2))
(inputs
(list openblas
lapack
@@ -5248,22 +5245,21 @@ (define trilinos-for-dealii-openmpi
"-DTrilinos_ENABLE_Ifpack2=OFF"
"-DTeuchos_ENABLE_FLOAT=ON"
"-DTpetra_INST_INT_LONG=ON"
+ ;; Disabling Tpetra_INST_INT_LONG_LONG is required only
+ ;; because Tpetra's CMakeLists.txt [1] is incorrectly
+ ;; testing for
+ ;;
+ ;; DEFINED Tpetra_INST_INT_LONG AND Tpetra_INST_INT_UNSIGNED_LONG
+ ;;
+ ;; instead of
+ ;;
+ ;; DEFINED Tpetra_INST_INT_LONG AND Tpetra_INST_INT_LONG
+ ;;
+ ;; [1]: https://github.com/trilinos/Trilinos/blob/0976cf2a8f9ee2991f4fb479f1056ca569eb22b9/packages/tpetra/CMakeLists.txt#L697
+ "-DTpetra_INST_INT_LONG_LONG=OFF"
"-DTPL_ENABLE_Boost=OFF")
#:phases
#~(modify-phases %standard-phases
- (add-after 'configure 'fix-kokkos-config
- (lambda _
- ;; GNU Make 4.3 accidentally leaves the backslash preceding
- ;; the number sign in strings containing a literal
- ;; backslash–number sign (\#) [1, 2].
- ;; This is still an issue in Trilinos 13.0.1, but should be
- ;; fixed in the following version.
- ;; (The latest versions of Kokkos incorporate the fix [2].)
- ;;
- ;; [1]: https://github.com/GEOSX/thirdPartyLibs/issues/136
- ;; [2]: https://github.com/kokkos/kokkos/blob/3.4.00/Makefile.kokkos#L441
- (substitute* "KokkosCore_config.h"
- (("\\\\#") "#"))))
(add-before 'check 'mpi-setup
#$%openmpi-setup))))
(home-page "https://trilinos.github.io/")