diff mbox series

[bug#56760,v2,1/6] gnu: trilinos-for-dealii-openmpi: Fix build.

Message ID 20220725151135.3924177-2-paul@apatience.com
State Accepted
Headers show
Series dealii: Update to 9.4.0 and its Trilinos to 13.4.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience July 25, 2022, 3:11 p.m. UTC
* gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[native-inputs]:
Add gcc-7 to fix the failing build with newer versions of gcc.
---
 gnu/packages/maths.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

--
2.37.1
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 458bffee61..948776e9d4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5153,7 +5153,10 @@  (define trilinos-for-dealii-openmpi
         (base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))))
     (build-system cmake-build-system)
     (native-inputs
-     `(("gfortran" ,gfortran)
+     `(;; The build fails with the current gcc.
+       ;; Use the version from when Trilinos was added.
+       ("gcc" ,gcc-7)
+       ("gfortran" ,gfortran)
        ;; Trilinos's repository contains several C-shell scripts, but adding
        ;; tcsh to the native inputs does not result in the check phase running
        ;; any more tests than without it (nor is tcsh required to build