diff mbox series

[bug#56705] gnu: Add font-latin-modern.

Message ID 20220722113554.3896-1-mcsinyx@disroot.org
State Accepted
Headers show
Series [bug#56705] gnu: Add font-latin-modern. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

vasilii.smirnov--- via Guix-patches" via July 22, 2022, 11:35 a.m. UTC
* gnu/packages/fonts.scm (font-latin-modern): New variable.
---
 gnu/packages/fonts.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

vasilii.smirnov--- via Guix-patches" via Aug. 18, 2022, 6:06 a.m. UTC | #1
Could someone please take a look at this?
Ricardo Wurmus Aug. 18, 2022, 8:56 p.m. UTC | #2
Thank you for your patch!  I broke the long line of the description into
a paragraph and pushed the patch to the master branch with commit
“9cde566b9cd84c999c0074c906928e2cbef1ef30”.
vasilii.smirnov--- via Guix-patches" via Aug. 19, 2022, 4:44 a.m. UTC | #3
Thanks!  BTW how do I subscribe to a specific debbugs ticket
(not the whole guix-patches)?  I did not get your response,
only the ticket done notification.
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a381f061af94..f7fa124edf00 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
 ;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
+;;; Copyright © 2022 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -731,6 +732,23 @@  (define-public font-tex-gyre
 Heros, Pagella, Schola, Termes.")
     (license license:gfl1.0)))
 
+(define-public font-latin-modern
+  (package
+    (name "font-latin-modern")
+    (version "2.004")
+    (source
+     (origin
+       (method url-fetch/zipbomb)
+       (uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
+                           "latin-modern/download/lm" version "otf.zip"))
+       (sha256
+        (base32 "06qnvd6kh07gy2197vx3nmskhiqhp7ip9cpi2rkbwa1p3l2kc0jv"))))
+    (build-system font-build-system)
+    (home-page "http://www.gust.org.pl/projects/e-foundry/latin-modern")
+    (synopsis "OpenType fonts based on Computer Modern")
+    (description "The Latin Modern fonts are a set of scalable fonts based on the PostScript Type 1 version of the Computer Modern fonts and contain many additional characters (mostly accented ones).  This package provides the OpenType variant of these fonts.")
+    (license license:gfl1.0)))
+
 (define-public font-amiri
   (package
     (name "font-amiri")