diff mbox series

[bug#56478,v2] gnu: Add cl-string-pokemonize.

Message ID 20220720051226.23611-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#56478,v2] gnu: Add cl-string-pokemonize. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart July 20, 2022, 5:12 a.m. UTC
* gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.

Hi, LiLiAnA

HeRe'S VeRsIoN 2.

ThAnK YoU fOR tHe ReViEw!!!

AlL bEsT,

jGaRt

---
 gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Liliana Marie Prikler July 20, 2022, 4:58 p.m. UTC | #1
Am Mittwoch, dem 20.07.2022 um 00:12 -0500 schrieb jgart:
> * gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.
> 
> Hi, LiLiAnA
> 
> HeRe'S VeRsIoN 2.
> 
> ThAnK YoU fOR tHe ReViEw!!!
> 
> AlL bEsT,
> 
> jGaRt
> 
> ---
>  gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)
> 
> diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
> index 2f6d22fe7d..0ada001bb9 100644
> --- a/gnu/packages/lisp-xyz.scm
> +++ b/gnu/packages/lisp-xyz.scm
> @@ -22715,6 +22715,39 @@ (define-public cl-sketch
>  (define-public ecl-sketch
>    (sbcl-package->ecl-package sbcl-sketch))
>  
> +(define-public sbcl-string-pokemonize
> +  (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
> +        (revision "0"))
> +    (package
> +     (name "sbcl-string-pokemonize")
> +     (version (git-version "20210503" revision commit))
> +     (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/phoe/string-pokemonize")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
> +     (build-system asdf-build-system/sbcl)
> +     (arguments
> +      `(#:tests? #f ; There are no tests.
> +        #:asd-files '("string-pokemonize.asd")
> +        #:asd-systems '("string-pokemonize")))
> +     (synopsis "aLtErNaTe uPpEr aNd lOwErCaSe")
I didn't mean to actually alternate the case in the synopsis.  Is this
intended or should I fix it?
> +     (description
> +"@code{string-pokemonize} provides a function that alternates
> uppercase
> +and lowercase characters for a given string.")
> +     (home-page "https://github.com/phoe/string-pokemonize")
> +     (license license:expat))))
> +
> +(define-public cl-string-pokemonize
> +  (sbcl-package->cl-source-package sbcl-string-pokemonize))
> +
> +(define-public ecl-string-pokemonize
> +  (sbcl-package->ecl-package sbcl-string-pokemonize))
> +
>  (define-public sbcl-binary-types
>    (let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
>      (package
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2f6d22fe7d..0ada001bb9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22715,6 +22715,39 @@  (define-public cl-sketch
 (define-public ecl-sketch
   (sbcl-package->ecl-package sbcl-sketch))
 
+(define-public sbcl-string-pokemonize
+  (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
+        (revision "0"))
+    (package
+     (name "sbcl-string-pokemonize")
+     (version (git-version "20210503" revision commit))
+     (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/phoe/string-pokemonize")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
+     (build-system asdf-build-system/sbcl)
+     (arguments
+      `(#:tests? #f ; There are no tests.
+        #:asd-files '("string-pokemonize.asd")
+        #:asd-systems '("string-pokemonize")))
+     (synopsis "aLtErNaTe uPpEr aNd lOwErCaSe")
+     (description
+"@code{string-pokemonize} provides a function that alternates uppercase
+and lowercase characters for a given string.")
+     (home-page "https://github.com/phoe/string-pokemonize")
+     (license license:expat))))
+
+(define-public cl-string-pokemonize
+  (sbcl-package->cl-source-package sbcl-string-pokemonize))
+
+(define-public ecl-string-pokemonize
+  (sbcl-package->ecl-package sbcl-string-pokemonize))
+
 (define-public sbcl-binary-types
   (let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
     (package