diff mbox series

[bug#55958] gnu: Add node-buffer-crc32.

Message ID 20220719212859.26080-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#55958] gnu: Add node-buffer-crc32. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves July 19, 2022, 9:28 p.m. UTC
* gnu/packages/node-xyz.scm (node-buffer-crc32): New variable.
---
 gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 9dcb5c3d16..d6035e2c23 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -56,6 +56,36 @@  (define-public node-acorn
 architecture supporting plugins.")
     (license license:expat)))
 
+(define-public node-buffer-crc32
+  (package
+    (name "node-buffer-crc32")
+    (version "0.2.13")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/brianloveswords/buffer-crc32")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+          (base32
+           "09qx2mnd898190m50mc0rhyvbm7d677sxz9bn09qmqkz6fnsddgf"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (invoke "npm" "--offline"
+                     "--ignore-scripts" "install" "--production"))))))
+    (home-page "https://github.com/brianloveswords/buffer-crc32")
+    (synopsis "CRC32 implementation in Javascript")
+    (description "This package provides a CRC32 algorithm that works with
+binary data and fancy character sets, signed or unsigned data and has tests,
+for Node.")
+    (license license:expat)))
+
 (define-public node-color-name
   (package
     (name "node-color-name")