diff mbox series

[bug#56645,2/3] gnu: gnuplot: Use G-expressions.

Message ID 20220719163451.108192-2-paul@apatience.com
State Accepted
Headers show
Series gnu: gnuplot: Update package style and bump version to 5.4.4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience July 19, 2022, 4:35 p.m. UTC
* gnu/packages/maths.scm (gnuplot)[arguments]: Use G-expressions.
---
 gnu/packages/maths.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

--
2.37.0
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8bbc0df077..1409fd9cb0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1134,11 +1134,12 @@  (define-public gnuplot
      (list pkg-config texlive-tiny))
     (inputs
      (list cairo gd lua pango readline))
-    (arguments `(#:configure-flags (list (string-append
-                                          "--with-texdir=" %output
-                                          "/texmf-local/tex/latex/gnuplot"))
-                 ;; Plot on a dumb terminal during tests.
-                 #:make-flags '("GNUTERM=dumb")))
+    (arguments
+     (list #:configure-flags
+           #~(list (string-append "--with-texdir=" #$output
+                                  "/texmf-local/tex/latex/gnuplot"))
+           ;; Plot on a dumb terminal during tests.
+           #:make-flags #~'("GNUTERM=dumb")))
     (home-page "http://www.gnuplot.info")
     (synopsis "Command-line driven graphing utility")
     (description "Gnuplot is a portable command-line driven graphing