diff mbox series

[bug#56571,v2,4/7] Update rust-textwrap

Message ID 20220716193413.1092916-4-me@kiranshila.com
State New
Headers show
Series [bug#56571,v2,1/7] Update the rust-windows crates | expand

Commit Message

Kiran Shila July 16, 2022, 7:34 p.m. UTC
---
 gnu/packages/crates-io.scm | 42 +++++++++++++++++++++++++++++---------
 1 file changed, 32 insertions(+), 10 deletions(-)

Comments

M July 19, 2022, 2:47 p.m. UTC | #1
Kiran Shila schreef op za 16-07-2022 om 12:34 [-0700]:
> +    (synopsis
> +     "Powerful library for word wrapping, indenting, and dedenting
> strings")
> +    (description
> +     "Powerful library for word wrapping, indenting, and dedenting
> strings")
> +    (license license:expat)))

Why this synopsis and description instead of ...


>  (define-public rust-textwrap-0.12
>    (package
> +    (inherit rust-textwrap-0.15)
>      (name "rust-textwrap")
>      (version "0.12.1")
>      (source
> @@ -62556,16 +62587,7 @@ (define-public rust-textwrap-0.12
>         #:cargo-inputs
>         (("rust-hyphenation" ,rust-hyphenation-0.8)
>          ("rust-terminal-size" ,rust-terminal-size-0.1)
> -        ("rust-unicode-width" ,rust-unicode-width-0.1))))
> -    (home-page
> -     "https://github.com/mgeisler/textwrap")
> -    (synopsis "Library for word wrapping, indenting, and dedenting
> strings")
> -    (description
> -     "Textwrap is a small library for word wrapping, indenting, and
> dedenting
> -strings.  You can use it to format strings (such as help and error
> messages)
> -for display in commandline applications.  It is designed to be
> efficient and
> -handle Unicode characters correctly.")
> -    (license license:expat)))

... this one?  The latter looks strictly better to me.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2d10e91b3e..d6c6126c39 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -62537,8 +62537,39 @@  (define-public rust-text-size-1
     (description "This package provides a newtypes for text offsets")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-textwrap-0.15
+  (package
+    (name "rust-textwrap")
+    (version "0.15.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "textwrap" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1yw513k61lfiwgqrfvsjw1a5wpvm0azhpjr2kr0jhnq9c56is55i"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-hyphenation" ,rust-hyphenation-0.8)
+                       ("rust-smawk" ,rust-smawk-0.3)
+                       ("rust-terminal-size" ,rust-terminal-size-0.1)
+                       ("rust-unicode-linebreak" ,rust-unicode-linebreak-0.1)
+                       ("rust-unicode-width" ,rust-unicode-width-0.1))
+       #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-lipsum" ,rust-lipsum-0.8)
+                                   ("rust-termion" ,rust-termion-1)
+                                   ("rust-unic-emoji-char" ,rust-unic-emoji-char-0.9)
+                                   ("rust-version-sync" ,rust-version-sync-0.9))))
+    (home-page "https://github.com/mgeisler/textwrap")
+    (synopsis
+     "Powerful library for word wrapping, indenting, and dedenting strings")
+    (description
+     "Powerful library for word wrapping, indenting, and dedenting strings")
+    (license license:expat)))
+
 (define-public rust-textwrap-0.12
   (package
+    (inherit rust-textwrap-0.15)
     (name "rust-textwrap")
     (version "0.12.1")
     (source
@@ -62556,16 +62587,7 @@  (define-public rust-textwrap-0.12
        #:cargo-inputs
        (("rust-hyphenation" ,rust-hyphenation-0.8)
         ("rust-terminal-size" ,rust-terminal-size-0.1)
-        ("rust-unicode-width" ,rust-unicode-width-0.1))))
-    (home-page
-     "https://github.com/mgeisler/textwrap")
-    (synopsis "Library for word wrapping, indenting, and dedenting strings")
-    (description
-     "Textwrap is a small library for word wrapping, indenting, and dedenting
-strings.  You can use it to format strings (such as help and error messages)
-for display in commandline applications.  It is designed to be efficient and
-handle Unicode characters correctly.")
-    (license license:expat)))
+        ("rust-unicode-width" ,rust-unicode-width-0.1))))))
 
 (define-public rust-textwrap-0.11
   (package