diff mbox series

[bug#56599] gnu: fortune-mod: Remove off database.

Message ID 20220716122126.26328-1-raingloom@riseup.net
State Accepted
Headers show
Series [bug#56599] gnu: fortune-mod: Remove off database. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Csepp July 16, 2022, 12:21 p.m. UTC
* gnu/packages/games.scm (fortune-mod): Delete off database after install phase.
---
 gnu/packages/games.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

kiasoc5 Aug. 3, 2022, 3:02 p.m. UTC | #1
Censorship is a tricky term, and it does not directly address why the
database is being removed. The phase should be more simply renamed to
remove-offensive-database, and include a comment on why the database is
being removed, referencing #54691.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 713f9339b2..cf10ebc9b6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7721,7 +7721,10 @@  (define-public fortune-mod
                  (lambda _
                    (with-directory-excursion #$output
                      (rename-file "games/fortune" "bin/fortune")
-                     (rmdir "games")))))))
+                     (rmdir "games"))))
+               (add-after 'install 'commit-censorship
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (delete-file-recursively (string-append (assoc-ref outputs "out") "/share/fortunes/off/")))))))
     (inputs (list recode))
     (native-inputs
      (list perl