diff mbox series

[bug#56534] gnu: racket: Add add ffmpeg and portaudio to inputs.

Message ID 20220713113951.6375-1-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#56534] gnu: racket: Add add ffmpeg and portaudio to inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Rostislav Svoboda July 13, 2022, 11:39 a.m. UTC
* ffmpeg and portaudio are required by '#lang video'. See
https://docs.racket-lang.org/video@video/Installing.html#%28part._ffmpeg-specs%29
---
 gnu/packages/racket.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Rostislav Svoboda Oct. 24, 2022, 12:13 p.m. UTC | #1
#lang video got out of my focus, but I just discovered this "A Short
Example of Packaging for GNU Guix with Racket."
https://youtu.be/0tznTxEmuRs where Tassos did the same.
Cheers
Steve George April 1, 2024, 8:34 a.m. UTC | #2
Hi,

Looks like a lot was done to add a 'racket-with-video' package to Guix.

Any way we can get this over the line? It was a bit unclear if it works and is ready?

Futurile
diff mbox series

Patch

diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 3399bcc3fe..8a54e2ece4 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -35,6 +35,7 @@  (define-module (gnu packages racket)
   #:use-module (srfi srfi-34)
   #:use-module (ice-9 match)
   #:use-module (gnu packages)
+  #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages chez)
@@ -51,6 +52,7 @@  (define-module (gnu packages racket)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages video)
   #:use-module (gnu packages xorg)
   #:use-module ((guix licenses) #:prefix license:))
 
@@ -591,6 +593,7 @@  (define-public racket
      (list
       cairo
       fontconfig
+      ffmpeg
       glib
       glu
       gmp
@@ -601,6 +604,7 @@  (define-public racket
       mesa
       mpfr
       pango
+      portaudio
       unixodbc
       libedit ;; TODO reconsider in light of expeditor and readline-gpl
       racket-minimal ;; <-- TODO non-tethered layer
@@ -933,6 +937,7 @@  (define-public racket
                                      name)))))
                                '("cairo"
                                  "fontconfig-minimal" ;; aka fontconfig
+                                 "ffmpeg"
                                  "glib"
                                  "glu"
                                  "gmp"
@@ -943,6 +948,7 @@  (define-public racket
                                  "mesa"
                                  "mpfr"
                                  "pango"
+                                 "portaudio"
                                  "unixodbc"
                                  "libedit"))))))))
     (synopsis "Programmable programming language in the Scheme family")