diff mbox series

[bug#56478] gnu: Add cl-string-pokemonize.

Message ID 20220710084107.11471-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#56478] gnu: Add cl-string-pokemonize. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart July 10, 2022, 8:41 a.m. UTC
* gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.
---
 gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

jgart July 21, 2022, 11:08 p.m. UTC | #1
> I didn't mean to actually alternate the case in the synopsis.  Is this
> intended or should I fix it?

I intended that but if you prefer for it to not be in pokemon case for
consistency with other Guix packages then feel free to change it and not use
the pokemon case in the synopsis.

all best,

jGaRt
Liliana Marie Prikler Aug. 16, 2022, 7:28 p.m. UTC | #2
Am Donnerstag, dem 21.07.2022 um 18:08 -0500 schrieb jgart:
> > I didn't mean to actually alternate the case in the synopsis.  Is
> > this intended or should I fix it?
> 
> I intended that but if you prefer for it to not be in pokemon case
> for consistency with other Guix packages then feel free to change it
> and not use the pokemon case in the synopsis.
PuShEd wItHoUt tHe pOkEmOn cAsE SyNoPsIs.

ChEeRs
jgart Aug. 16, 2022, 7:52 p.m. UTC | #3
On Sun, 10 Jul 2022 03:41:07 -0500 jgart <jgart@dismail.de> wrote:

ThAnKs!
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 129b99e485..18c36ec3f6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -22647,6 +22647,41 @@  (define-public cl-sketch
 (define-public ecl-sketch
   (sbcl-package->ecl-package sbcl-sketch))
 
+(define-public sbcl-string-pokemonize
+  (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
+        (revision "0"))
+    (package
+     (name "sbcl-string-pokemonize")
+     (version (git-version "20210503" revision commit))
+     (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/phoe/string-pokemonize")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
+     (build-system asdf-build-system/sbcl)
+     (arguments
+      `(#:tests? #f ; There are no tests.
+        #:asd-files '("string-pokemonize.asd")
+        #:asd-systems '("string-pokemonize")))
+     (synopsis "Function to alternate uppercase and lowercase characters")
+     (description
+"Provides a function, @code{string-pokemonize} that alternates uppercase
+and lowercase characters for a given string. The entire code base is
+also entirely stylized in alternating uppercase and lowercase characters
+exemplifying Common Lisp's case insensitivity.")
+     (home-page "https://github.com/phoe/string-pokemonize")
+     (license license:expat))))
+
+(define-public cl-string-pokemonize
+  (sbcl-package->cl-source-package sbcl-string-pokemonize))
+
+(define-public ecl-string-pokemonize
+  (sbcl-package->ecl-package sbcl-string-pokemonize))
+
 (define-public sbcl-binary-types
   (let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
     (package