diff mbox series

[bug#56471] gnu: Add python-bsdiff4.

Message ID 20220709183437.7228-1-antero@mailbox.org
State Accepted
Headers show
Series [bug#56471] gnu: Add python-bsdiff4. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr July 9, 2022, 6:34 p.m. UTC
* gnu/packages/python-xyz.scm (python-bsdiff4): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Ludovic Courtès July 19, 2022, 8:59 p.m. UTC | #1
Hi,

Antero Mejr <antero@mailbox.org> skribis:

> * gnu/packages/python-xyz.scm (python-bsdiff4): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f4867ece0..16193ba0d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30125,3 +30125,24 @@  (define-public python-geomet
 GeoJSON to WKT/WKB (Well-Known Text/Binary) or GeoPackage Binary, and vice
 versa.  Extended WKB/WKT are also supported.")
     (license license:asl2.0)))
+
+(define-public python-bsdiff4
+  (package
+    (name "python-bsdiff4")
+    (version "1.2.2")
+    (home-page "https://github.com/ilanschnell/bsdiff4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1fa0vkmbr0a9xifq7i5gfcf7ifn739i1fdij8awynm299fsqvvhx"))))
+    (build-system python-build-system)
+    (synopsis "Binary diff and patch using the BSDIFF4-format")
+    (description "This package provides a Python library for the @code{bsdiff}
+binary diff utility.  It also provides two command-line tools, @code{bsdiff4}
+and @code{bspatch4}.")
+    (license license:bsd-2)))