diff mbox series

[bug#56390,1/1] gnu: Add texlive-babel-dutch.

Message ID 20220705063943.26065-1-wz@freeshell.de
State Accepted
Headers show
Series gnu: Add texlive-babel-dutch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny July 5, 2022, 6:39 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-babel-dutch): New variable.
---
 gnu/packages/tex.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Ludovic Courtès July 11, 2022, 11:14 p.m. UTC | #1
Hi,

Wiktor Żelazny <wz@freeshell.de> skribis:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-babel-dutch): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f6b4c25595..88de0774c6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10981,3 +10981,29 @@  (define-public texlive-lineno
 mechanism.  Line numbering may be extended to footnote lines, using the
 fnlineno package.")
     (license license:lppl1.3a+)))
+
+(define-public texlive-babel-dutch
+  (let ((template (simple-texlive-package
+                   "texlive-babel-dutch"
+                   (list "/source/generic/babel-dutch/")
+                   (base32
+                    "1a40rz6rznawgarnhk0wh751sln2x9js4420i0758y2clf4rlhg9"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "generic/babel-dutch")
+         ((#:build-targets _ '())
+          ''("dutch.ins")) ; TODO: use dtx and build documentation
+         ((#:phases phases) `(modify-phases ,phases
+                               (add-after 'unpack 'chdir
+                                 (lambda _
+                                   (chdir "source/generic/babel-dutch")))))))
+      (home-page "https://www.ctan.org/pkg/babel-dutch")
+      (synopsis "Babel support for Dutch")
+      (description
+       "This package provides the language definition file for support of Dutch
+in @code{babel}.  It provides all the necessary macros, definitions and
+settings to typeset Dutch documents.")
+      (license license:lppl1.3c+))))