diff mbox series

[bug#52997] gnu: Add python-facebook-sdk.

Message ID 20220701214325.17848-1-goodoldpaul@autistici.org
State New
Headers show
Series [bug#52997] gnu: Add python-facebook-sdk. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi July 1, 2022, 9:43 p.m. UTC
* gnu/packages/python-web.scm (python-facebook-sdk): New variable.
---
 gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: aba1ee5553099d45eb22d9ca1f685502146a49d0
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6f951595c8..fc61951b3c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7183,6 +7183,35 @@  (define-public python-tweepy
 library for accessing the Twitter API.")
     (license license:expat)))
 
+(define-public python-facebook-sdk
+  (package
+    (name "python-facebook-sdk")
+    (version "3.1.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+         (git-reference
+          (url "https://github.com/mobolic/facebook-sdk")
+          (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0p7p0wvcspd9p8d6r25bgjbf0ihdw5g1jw3dylwngrazdmc3g36b"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests require network access.
+     `(#:tests? #f))
+    (propagated-inputs `(("python-requests" ,python-requests)))
+    (home-page "https://facebook-sdk.readthedocs.io")
+    (synopsis
+      "Facebook Graph API client in Python")
+    (description
+      "This client library is designed to support the Facebook Graph API and
+the official Facebook JavaScript SDK, which is the canonical way to implement
+Facebook authentication.")
+    (license license:asl2.0)))
+
 (define-public python-quart
   (package
     (name "python-quart")