diff mbox series

[bug#52576] gnu: ibus-anthy: Update to 1.15.12

Message ID 20220630221547.3ba3cee3@ens-lyon.fr
State Accepted
Headers show
Series [bug#52576] gnu: ibus-anthy: Update to 1.15.12 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Alice BRENON June 30, 2022, 8:15 p.m. UTC
Alright, thanks for the last missing piece of the puzzle.

Here is a fix hopefully not too different from the one you'd have
written. If everyone agrees on it, I think someone with commit rights
could merge it on master even before you come back closer to a proper
keyboard to avoid more users hitting the problem. And, in any case,
before this happens there's the quickfix I suggested above : )

Cheers,

Alice

Le Wed, 29 Jun 2022 22:25:24 -0400,
Maxim Cournoyer <maxim.cournoyer@gmail.com> a écrit :

> On June 29, 2022 10:35:04 AM EDT, Alice BRENON
> <alice.brenon@ens-lyon.fr> wrote:
> 
> [...]
> 
> >And now all I want to know is if we can revert `inputs` back to
> >`outputs` or if there is a good reason not to do so, and hence what
> >should be done in that case, but it seems that it is a matter on
> >which Maxim Cournoyer has the expertise, since he was the one to
> >introduce the change.  
> 
> [...]
> 
> Seems an oversight on my part, apologies!  'inputs' in
> 
> + ,(search-input-directory
> + inputs "lib/girepository-1.0")))))
> 
> Should have been 'outputs'.  Unfortunately I'm nowhere near a
> keyboard for a week, so won't be able to commit the trivial fix in
> that time.
> 
> Thanks,
> 
> Maxim
> 
> Hi,
diff mbox series

Patch

From e851ab2c68cb2fab26bf686d56fdb1488ef9e78d Mon Sep 17 00:00:00 2001
From: Alice BRENON <alice.brenon@ens-lyon.fr>
Date: Thu, 30 Jun 2022 22:02:22 +0200
Subject: [PATCH] gnu: ibus-anthy: Fix wrapped programs

This is in follow up to 89db6e7ec77bf0f33474e47945755f5ab45e9f06, the
proper fix wasn't to add inputs to the arguments but to use outputs to
set the GI_TYPELIB_PATH.

* gnu/packages/ibus.scm (ibus-anthy)
[phase]{wrap-programs}: Search within outputs instead of inputs to set
GI_TYPELIB_PATH.
---
 gnu/packages/ibus.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 234d4bd75f..9e8b0f124b 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -329,7 +329,7 @@  (define-public ibus-anthy
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap-programs
-           (lambda* (#:key inputs outputs #:allow-other-keys)
+           (lambda* (#:key outputs #:allow-other-keys)
              (for-each (lambda (prog)
                          (wrap-program (search-input-file
                                         outputs (string-append "libexec/" prog))
@@ -338,7 +338,7 @@  (define-public ibus-anthy
                            `("GI_TYPELIB_PATH" ":" prefix
                              (,(getenv "GI_TYPELIB_PATH")
                               ,(search-input-directory
-                                inputs "lib/girepository-1.0")))))
+                                outputs "lib/girepository-1.0")))))
                        '("ibus-engine-anthy" "ibus-setup-anthy")))))))
     (native-inputs
      (list gettext-minimal
-- 
2.36.1