diff mbox series

[bug#56314] Add ghc-hosc

Message ID 20220630045109.17836-3-winterhound@yandex.com
State New
Headers show
Series [bug#56314] Add ghc-hosc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

WinterHound June 30, 2022, 4:51 a.m. UTC
---
 gnu/packages/haskell-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index eb1528b4a2..2198b3fa26 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16121,3 +16121,21 @@  (define-public ghc-singleton-bool
      "This package provides Type-level booleans.")
     (license license:bsd-3)))
 
+(define-public ghc-hosc
+  (package
+    (name "ghc-hosc")
+    (version "0.19.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "hosc" version))
+       (sha256
+        (base32 "08q218p1skqxwa7f55nsgmv9z8digf1c0f1wi6p562q6d4i044z7"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-blaze-builder
+                  ghc-network
+                  ghc-data-binary-ieee754))
+    (home-page "http://rohandrape.net/?t=hosc")
+    (synopsis "Haskell Open Sound Control")
+    (description "hosc implements a subset of the Open Sound Control byte protocol")
+    (license license:gpl3)))