diff mbox series

[bug#56315] Add ghc-microspec

Message ID 20220630045109.17836-2-winterhound@yandex.com
State New
Headers show
Series [bug#56315] Add ghc-microspec | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

WinterHound June 30, 2022, 4:51 a.m. UTC
---
 gnu/packages/haskell-check.scm | 55 +++++++++++++++++++++++-----------
 1 file changed, 37 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 62433cdb15..06c11e2ccb 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -1214,31 +1214,31 @@  (define-public ghc-tasty-silver
     (name "ghc-tasty-silver")
     (version "3.2.3")
     (source
-      (origin
-        (method url-fetch)
-        (uri (string-append
-               "https://hackage.haskell.org/package/tasty-silver/tasty-silver-"
-               version
-               ".tar.gz"))
-        (sha256
-          (base32 "0nvh2k8iqqkanmp7lpwd3asimyarzisly8wavbdahcxryn0j4xb7"))))
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/tasty-silver/tasty-silver-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32 "0nvh2k8iqqkanmp7lpwd3asimyarzisly8wavbdahcxryn0j4xb7"))))
     (build-system haskell-build-system)
     (inputs
-      (list ghc-ansi-terminal
-            ghc-async
-            ghc-optparse-applicative
-            ghc-process-extras
-            ghc-regex-tdfa
-            ghc-semigroups
-            ghc-tagged
-            ghc-tasty
-            ghc-temporary))
+     (list ghc-ansi-terminal
+           ghc-async
+           ghc-optparse-applicative
+           ghc-process-extras
+           ghc-regex-tdfa
+           ghc-semigroups
+           ghc-tagged
+           ghc-tasty
+           ghc-temporary))
     (native-inputs
      (list ghc-tasty-hunit ghc-silently))
     (home-page "https://github.com/phile314/tasty-silver")
     (synopsis "Fancy test runner, including support for golden tests")
     (description
-      "This package provides a fancy test runner and support for @dfn{golden
+     "This package provides a fancy test runner and support for @dfn{golden
 testing}.  A golden test is an IO action that writes its result to a file.  To
 pass the test, this output file should be identical to the corresponding
 ``golden'' file, which contains the correct result for the test.  The test
@@ -1246,3 +1246,22 @@  (define-public ghc-tasty-silver
 result of golden tests.")
     (license license:expat)))
 
+(define-public ghc-microspec
+  (package
+    (name "ghc-microspec")
+    (version "0.2.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "microspec" version))
+       (sha256
+        (base32 "0615gdbsk7i3w71adjp69zabw4mli965wffm2h846hp6pjj31xcb"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-quickcheck))
+    (home-page "http://hackage.haskell.org/package/microspec")
+    (synopsis "Tiny QuickCheck test library with minimal dependencies")
+    (description
+     "This package provides a tiny (1 module, <500 lines) property-based
+(and unit) testing library with minimal dependencies.")
+    (license license:bsd-3)))
+