diff mbox series

[bug#56274,1/1] gnu: Add python-gp-extras.

Message ID 20220628102611.32066-1-wz@freeshell.de
State New
Headers show
Series Add python-gp-extras | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny June 28, 2022, 10:26 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/machine-learning.scm (python-gp-extras): New variable.
---
 gnu/packages/machine-learning.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 53d428bd4f..6e364f99be 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
 ;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3096,3 +3097,29 @@  (define-public liblantern
     (description
      "Lantern provides a C API to the libtorch machine learning library.")
     (license license:expat)))
+
+(define-public python-gp-extras
+  (let ((commit "75bf73914d41d4d5f969da840315423fba2a2650") (revision "1"))
+    (package
+      (name "python-gp-extras")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jmetzen/gp_extras")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1vh2if3vczbfj41kdx2y53xd1rfjs12ysy19l9ba8dczp9rrlp0j"))))
+      (build-system python-build-system)
+      (propagated-inputs (list python-scikit-learn))
+      (home-page "https://jmetzen.github.io/2015-12-17/gp_extra.html")
+      (synopsis "Additional Kernels for sklearn's Gaussian Processes")
+      (description
+       "The @code{gp_extra} project contains some advanced,
+non-standard Gaussian process kernels that can seamlessly be used with
+@code{scikit-learn}'s @code{GaussianProcessRegressor}.")
+      ;; There's the license name in
+      ;; gp_extras/kernels/kernels_non_stationary.py, but not its text, so
+      ;; unsure whether it's valid from the legal standpoint.
+      (license license:bsd-3))))