diff mbox series

[bug#56266] gnu: Add r-bader.

Message ID 20220627212824.18326-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#56266] gnu: Add r-bader. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 27, 2022, 9:28 p.m. UTC
* gnu/packages/bioconductor.scm (r-bader): New variable.
---
 gnu/packages/bioconductor.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 144a750f8b10e606751bc887bcb09e7fb7ae09ff

Comments

Ricardo Wurmus Oct. 27, 2022, 1:45 p.m. UTC | #1
Applied with minor changes, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..6d65cc1c1f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,30 @@  (define-public r-aneufinder
 sequencing data.")
     (license license:artistic2.0)))
 
+(define-public r-bader
+  (package
+    (name "r-bader")
+    (version "1.34.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BADER" version))
+              (sha256
+               (base32
+                "0i5x1r2ns1hxhqk5jyfqird81hck1hllvvgx5bn0rb5vl99g8spm"))))
+    (properties `((upstream-name . "BADER")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/BADER")
+    (synopsis
+     "Bayesian analysis of differential expression in RNA sequencing data")
+    (description
+     "The @code{BADER} package is intended for the analysis of RNA sequencing
+data.  The algorithm fits a Bayesian hierarchical model for RNA sequencing count
+data.  @code{BADER} returns the posterior probability of differential expression
+for each gene between two groups A and B.  The joint posterior distribution of
+the variables in the model can be returned in the form of posterior samples,
+which can be used for further down-stream analyses such as gene set enrichment.")
+    (license license:gpl2)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")