diff mbox series

[bug#56265] gnu: Add r-bac.

Message ID 20220627211620.17299-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#56265] gnu: Add r-bac. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 27, 2022, 9:16 p.m. UTC
* gnu/packages/bioconductor.scm (r-bac): New variable.
---
 gnu/packages/bioconductor.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 144a750f8b10e606751bc887bcb09e7fb7ae09ff

Comments

Ricardo Wurmus Oct. 27, 2022, 1:44 p.m. UTC | #1
Applied with minor changes.  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..1e86f02128 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,30 @@  (define-public r-aneufinder
 sequencing data.")
     (license license:artistic2.0)))
 
+(define-public r-bac
+  (package
+    (name "r-bac")
+    (version "1.56.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BAC" version))
+              (sha256
+               (base32
+                "0dkw7438d2sf6nb577dnzija54qs0nhlr47lb73li60fhlnvqmh2"))))
+    (properties `((upstream-name . "BAC")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/BAC")
+    (synopsis "Bayesian analysis of Chip-chip experiment")
+    (description
+     "This package uses a Bayesian hierarchical model to detect enriched regions
+from ChIP-chip experiments.  The common goal in analyzing this ChIP-chip data is
+to detect DNA-protein interactions from ChIP-chip experiments.  The @code{BAC}
+package has mainly been tested with @code{Affymetrix} tiling array data.  However,
+we expect it to work with other platforms (e.g. Agilent, Nimblegen, cDNA, etc.).
+Note that @code{BAC} does not deal with normalization, so you will have to
+normalize your data before hands.")
+    (license license:artistic2.0)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")