diff mbox series

[bug#56243] gnu: python-debug: Improve description and synopsis.

Message ID 20220626220938.12896-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#56243] gnu: python-debug: Improve description and synopsis. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart June 26, 2022, 10:09 p.m. UTC
* gnu/packages/python.scm (python-debug): Improve description and
synopsis.
[synopsis]: Improve synopsis.
[description]: Improve description.
---
 gnu/packages/python.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

M June 26, 2022, 10:40 p.m. UTC | #1
jgart via Guix-patches via schreef op zo 26-06-2022 om 17:09 [-0500]:
>      (synopsis
> -     "High-level, dynamically-typed programming language (for debugging)")
> +     "Python with the debug hooks enabled")
>      (description
> -     "This variant of Python provides an interpreter built with
> -@code{--with-pydebug} to help develop and debug extensions.  See
> +"This variant of Python provides an interpreter
> +built with the @code{--with-pydebug} flag, enabling
> +debug hooks for development or testing purposes.  See
>  @url{https://pythonextensionpatterns.readthedocs.io/en/latest/debugging/debug.html},
>  for more information.")))

I can't tell whether the old or new description is better but the new
synopsis seems better to me (more to the point and descriptive -- you
can do debugging in the regular python too!).  Maybe it would be even
better to make clear in the description that you can also do debugging
with the _regular_ python package?

Greetings,
Maxime.
Maxim Cournoyer July 16, 2022, 3:54 a.m. UTC | #2
Hi,

Maxime Devos <maximedevos@telenet.be> writes:

> jgart via Guix-patches via schreef op zo 26-06-2022 om 17:09 [-0500]:
>>      (synopsis
>> -     "High-level, dynamically-typed programming language (for debugging)")
>> +     "Python with the debug hooks enabled")
>>      (description
>> -     "This variant of Python provides an interpreter built with
>> -@code{--with-pydebug} to help develop and debug extensions.  See
>> +"This variant of Python provides an interpreter
>> +built with the @code{--with-pydebug} flag, enabling
>> +debug hooks for development or testing purposes.  See
>>  @url{https://pythonextensionpatterns.readthedocs.io/en/latest/debugging/debug.html},
>>  for more information.")))
>
> I can't tell whether the old or new description is better but the new
> synopsis seems better to me (more to the point and descriptive -- you
> can do debugging in the regular python too!).  Maybe it would be even
> better to make clear in the description that you can also do debugging
> with the _regular_ python package?

I pushed the improved synopsis, but also had doubts about the
description change, so left it out in
15943fa75788edb8d9ed1c3d8d320f50d21e4baa.

Closing.

Thanks,

Maxim
jgart July 16, 2022, 4:04 a.m. UTC | #3
On Fri, 15 Jul 2022 23:54:25 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> I pushed the improved synopsis, but also had doubts about the
> description change, so left it out in
> 15943fa75788edb8d9ed1c3d8d320f50d21e4baa.

Hi Maxim,

Sorry I couldn't get to it in time but thanks for working on it.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ad475d8acc..6611e13096 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -617,10 +617,11 @@  (define-public python-debug
        ((#:configure-flags flags '())
         `(cons "--with-pydebug" ,flags))))
     (synopsis
-     "High-level, dynamically-typed programming language (for debugging)")
+     "Python with the debug hooks enabled")
     (description
-     "This variant of Python provides an interpreter built with
-@code{--with-pydebug} to help develop and debug extensions.  See
+"This variant of Python provides an interpreter
+built with the @code{--with-pydebug} flag, enabling
+debug hooks for development or testing purposes.  See
 @url{https://pythonextensionpatterns.readthedocs.io/en/latest/debugging/debug.html},
 for more information.")))