diff mbox series

[bug#56208] gnu: Add python-sendgrid.

Message ID 20220625042503.7243-1-antero@mailbox.org
State Accepted
Headers show
Series [bug#56208] gnu: Add python-sendgrid. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr June 25, 2022, 4:25 a.m. UTC
Depends on patch #56196 (python-http-client) and #56207 (python-starkbank-ecdsa).
https://issues.guix.gnu.org/56196
https://issues.guix.gnu.org/56207

* gnu/packages/python-web.scm (python-sendgrid): New variable.
---
 gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ludovic Courtès June 26, 2022, 9:18 p.m. UTC | #1
Antero Mejr <antero@mailbox.org> skribis:

> Depends on patch #56196 (python-http-client) and #56207 (python-starkbank-ecdsa).
> https://issues.guix.gnu.org/56196
> https://issues.guix.gnu.org/56207
>
> * gnu/packages/python-web.scm (python-sendgrid): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6c121907e6..1afa0ef487 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7546,3 +7546,27 @@  (define-public python-zeep
 @end itemize")
     (license license:expat)))
 
+(define-public python-sendgrid
+  (package
+    (name "python-sendgrid")
+    (version "6.9.7")
+    (home-page "https://github.com/sendgrid/sendgrid-python/")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0kvp4gm3bpcsj2mkv05pgvlcv1jlsfhcljcv61wz5kq9d273h7rg"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f)) ;241/340 tests fail due to attempted web access
+    (propagated-inputs (list python-http-client python-starkbank-ecdsa))
+    (synopsis "SendGrid API library for Python")
+    (description
+     "The @code{sendgrid} Python library allows access to the
+SendGrid Web API v3.  Version 3+ of the library provides full support for all
+SendGrid Web API v3 endpoints, including the new v3 /mail/send.")
+    (license license:expat)))