diff mbox series

[bug#56163] gnu: Add r-atsnp.

Message ID 20220623104631.25686-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#56163] gnu: Add r-atsnp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 23, 2022, 10:46 a.m. UTC
* gnu/packages/bioconductor.scm (r-atsnp): New variable.
---
 gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9

Comments

Ricardo Wurmus Oct. 31, 2022, 8:40 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..f4c5f6e17b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,39 @@  (define-public r-aneufinder
 sequencing data.")
     (license license:artistic2.0)))
 
+(define-public r-atsnp
+  (package
+    (name "r-atsnp")
+    (version "1.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "atSNP" version))
+              (sha256
+               (base32
+                "0dmv34xqwr3l2rznapxmyrkyf1w78qzxdv88s5nn8s1m8qdkgwkz"))))
+    (properties `((upstream-name . "atSNP")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocfilecache
+           r-biocparallel
+           r-bsgenome
+           r-data-table
+           r-ggplot2
+           r-lifecycle
+           r-motifstack
+           r-rappdirs
+           r-rcpp
+           r-testthat))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/sunyoungshin/atSNP")
+    (synopsis
+     "Affinity test for identifying regulatory single nucleotide polymorphisms")
+    (description
+     "The @code{atSNP} package performs affinity tests of motif matches with the
+@dfn{SNP} (single nucleotide polymorphism) or the reference genomes and SNP-led
+changes in motif matches.")
+    (license license:gpl2)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")