diff mbox series

[bug#54882,v4,2/6] gnu: Add go-git-sr-ht--emersion-go-scfg.

Message ID 20220623093808.21573-2-contact@dhruvin.dev
State Accepted
Headers show
Series [bug#54882,v4,1/6] gnu: Add go-github-com-google-shlex. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Dhruvin Gandhi June 23, 2022, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-git-sr-ht--emersion-go-scfg): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f7ea36c636..8e7460db02 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9866,3 +9866,26 @@  (define-public go-github-com-google-shlex
       "Package shlex implements a simple lexer which splits input into tokens using
 shell-style rules for quoting and commenting.")
     (license license:asl2.0)))
+
+(define-public go-git-sr-ht--emersion-go-scfg
+  (package
+    (name "go-git-sr-ht--emersion-go-scfg")
+    (version "0.0.0-20211215104734-c2c7a15d6c99")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://git.sr.ht/~emersion/go-scfg")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "02gn8hz8zfv8y0krysx2wv951gw8hmhdfqf1ysidwm7i293365w4"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "git.sr.ht/~emersion/go-scfg"))
+    (propagated-inputs
+      (list go-github-com-google-shlex
+            go-github-com-davecgh-go-spew))
+    (home-page "https://git.sr.ht/~emersion/go-scfg")
+    (synopsis "Go library for simple configuration file format")
+    (description "Package go-scfg parses scfg files.")
+    (license license:expat)))