diff mbox series

[bug#56094,v4] gnu: wm: Switch sway from elogind to basu.

Message ID 20220622103548.18453-1-mail@muradm.net
State Accepted
Headers show
Series [bug#56094,v4] gnu: wm: Switch sway from elogind to basu. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

muradm June 22, 2022, 10:35 a.m. UTC
* gnu/packages/wm.scm (sway):
[inputs]: Replace ‘elogind’ with ‘basu’.
[arguments]: Add -Dsd-bus-provider=basu flag.
---
 gnu/packages/wm.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

Comments

Liliana Marie Prikler June 22, 2022, 10:39 a.m. UTC | #1
Am Mittwoch, dem 22.06.2022 um 13:35 +0300 schrieb muradm:
> * gnu/packages/wm.scm (sway):
> [inputs]: Replace ‘elogind’ with ‘basu’.
> [arguments]: Add -Dsd-bus-provider=basu flag.
Tiny nitpick, should literally be “Add "-Dsd-bus-provider=basu"”
(see how quoting this is hard?)  You don't need to send a v5 though,
I'll just reword it once basu is ready.


Cheers
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index ecc79f73b9..0ea7641db3 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1572,7 +1572,10 @@  (define-public sway
         (base32 "0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
+     `(;; elogind is propagated by wlroots -> libseat
+       ;; and would otherwise shadow basu.
+       #:configure-flags '("-Dsd-bus-provider=basu")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'hardcode-paths
            (lambda* (#:key inputs #:allow-other-keys)
@@ -1587,8 +1590,8 @@  (define-public sway
                 (string-append "'" (assoc-ref inputs "scdoc")
                                "/bin/scdoc'")))
              #t)))))
-    (inputs (list cairo
-                  elogind
+    (inputs (list basu
+                  cairo
                   gdk-pixbuf
                   json-c
                   libevdev