diff mbox series

[bug#56134] gnu: python-parso: Update to 0.8.3.

Message ID 20220622042904.15512-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#56134] gnu: python-parso: Update to 0.8.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart June 22, 2022, 4:29 a.m. UTC
* gnu/packages/yyy.scm (python-parso): Update to 0.8.3.
[arguments]: Satisfy guix lint.
---
 gnu/packages/python-xyz.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

Comments

Christopher Baines June 23, 2022, 12:11 p.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/yyy.scm (python-parso): Update to 0.8.3.
> [arguments]: Satisfy guix lint.
> ---
>  gnu/packages/python-xyz.scm | 13 ++++++++-----
>  1 file changed, 8 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 194b342ee6..493ded6e12 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -21435,20 +21435,23 @@ (define-public python-onetimepass
>  (define-public python-parso
>    (package
>      (name "python-parso")
> -    (version "0.8.2")
> +    (version "0.8.3")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (pypi-uri "parso" version))
>         (sha256
> -        (base32 "161k8771m7w60qakyvrwf9q62lvakmix7mpfylpy7713qs939f0j"))))
> +        (base32 "185gkxq92kqiw2h5zp1cmyn04055x0lix4hmi5c077xm1clvw1wc"))))
>      (native-inputs
>       (list python-pytest))
>      (build-system python-build-system)
>      (arguments
> -     `(#:phases (modify-phases %standard-phases
> -                  (replace 'check
> -                    (lambda _ (invoke "pytest" "-vv"))))))
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda* (#:key tests? #:allow-other-keys)
> +             (when tests?
> +               (invoke "pytest" "-vv")))))))
>      (home-page "https://github.com/davidhalter/parso")
>      (synopsis "Python Parser")
>      (description "Parso is a Python parser that supports error recovery and

Thanks, I've pushed this as 8e2ff622ed7e493a644ebcff62299d2ed1c4e806.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 194b342ee6..493ded6e12 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21435,20 +21435,23 @@  (define-public python-onetimepass
 (define-public python-parso
   (package
     (name "python-parso")
-    (version "0.8.2")
+    (version "0.8.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "parso" version))
        (sha256
-        (base32 "161k8771m7w60qakyvrwf9q62lvakmix7mpfylpy7713qs939f0j"))))
+        (base32 "185gkxq92kqiw2h5zp1cmyn04055x0lix4hmi5c077xm1clvw1wc"))))
     (native-inputs
      (list python-pytest))
     (build-system python-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda _ (invoke "pytest" "-vv"))))))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv")))))))
     (home-page "https://github.com/davidhalter/parso")
     (synopsis "Python Parser")
     (description "Parso is a Python parser that supports error recovery and