diff mbox series

[bug#56115] python-build-system: Fix typo in module-level comment paragraph.

Message ID 20220620211733.14137-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#56115] python-build-system: Fix typo in module-level comment paragraph. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart June 20, 2022, 9:17 p.m. UTC
* guix/build/python-build-system.scm: Fix typo in comment paragraph.
---
 guix/build/python-build-system.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Maxim Cournoyer June 22, 2022, 6:40 p.m. UTC | #1
Hi,

jgart <jgart@dismail.de> writes:

> * guix/build/python-build-system.scm: Fix typo in comment paragraph.
> ---
>  guix/build/python-build-system.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
> index 08871f60cd..28041e90a3 100644
> --- a/guix/build/python-build-system.scm
> +++ b/guix/build/python-build-system.scm
> @@ -68,7 +68,7 @@ (define-module (guix build python-build-system)
>  ;; downloading the package source from PyPI (the Python Package Index).  Both
>  ;; of them import setuptools and execute the "setup.py" file under their
>  ;; control.  Thus the "setup.py" behaves as if the developer had imported
> -;; setuptools within setup.py - even is still using only distutils.
> +;; setuptools within setup.py - even if it is still using only distutils.
>  ;;
>  ;; Setuptools' "install" command (to be more precise: the "easy_install"
>  ;; command which is called by "install") will put the path of the currently

Thanks.  Unfortunately this simply typo fix causes a world rebuild.  I'd
suggest flagging such patches with the 'core-updates PATCH' prefix, as
hinted in info '(guix) Submitting Patches' to avoid committers from
unintentionally pushing these to master.

Applied to core-updates.

Closing!

Maxim
jgart June 23, 2022, 12:48 a.m. UTC | #2
On Wed, 22 Jun 2022 14:40:22 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> Thanks.  Unfortunately this simply typo fix causes a world rebuild.  I'd
> suggest flagging such patches with the 'core-updates PATCH' prefix, as
> hinted in info '(guix) Submitting Patches' to avoid committers from
> unintentionally pushing these to master.
> 
> Applied to core-updates.

Thanks! I'll keep that in mind on the next one and I'll try to add a note in the docs soon about this unless you do first.

all best,

jgart
diff mbox series

Patch

diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 08871f60cd..28041e90a3 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -68,7 +68,7 @@  (define-module (guix build python-build-system)
 ;; downloading the package source from PyPI (the Python Package Index).  Both
 ;; of them import setuptools and execute the "setup.py" file under their
 ;; control.  Thus the "setup.py" behaves as if the developer had imported
-;; setuptools within setup.py - even is still using only distutils.
+;; setuptools within setup.py - even if it is still using only distutils.
 ;;
 ;; Setuptools' "install" command (to be more precise: the "easy_install"
 ;; command which is called by "install") will put the path of the currently