diff mbox series

[bug#56111] gnu: playerctl: update to 2.4.1.

Message ID 20220620170517.18322-1-josegpt27@gmail.com
State Accepted
Headers show
Series [bug#56111] gnu: playerctl: update to 2.4.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jose G Perez Taveras June 20, 2022, 5:05 p.m. UTC
Hello,

Here is an update to playerctl to 2.4.1 and fixed dependencies.
It uses `dbus-launch' to start a new daemon.

This is my first time sending a patch, I would be very happy if you
could point me out to anything I should know.

Thank you,
josegpt

---
 gnu/packages/music.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Christopher Baines June 21, 2022, 11:29 a.m. UTC | #1
Jose G Perez Taveras <josegpt27@gmail.com> writes:

> Hello,
>
> Here is an update to playerctl to 2.4.1 and fixed dependencies.
> It uses `dbus-launch' to start a new daemon.
>
> This is my first time sending a patch, I would be very happy if you
> could point me out to anything I should know.

Hi Jose,

Thanks for the patch.

> +    (propagated-inputs (list dbus))

The addition of dbus as a propagated input was the only thing that stood
out to me.

If playerctl does call out to dbus-launch, then patching the source to
refer to the specific /gnu/store/...-dbus/.../dbus-launch binary would
be the nicest approach, since that would avoid propagating dbus.

Is it necessary to propagate the dbus package, and if so, what doesn't
work if you don't?

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cb176320..86a1d64ff9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -48,6 +48,7 @@ 
 ;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5562,7 +5563,7 @@  (define-public pragha
 (define-public playerctl
   (package
     (name "playerctl")
-    (version "2.2.1")
+    (version "2.4.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5571,14 +5572,15 @@  (define-public playerctl
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "17hi33sw3663qz5v54bqqil31sgkrlxkb2l5bgqk87pac6x2wnbz"))))
+                "0ij065blj3h5v6iivvpmgh1095vicj1nc7hp1nhlhpqagd98l89s"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Dintrospection=false" "-Dgtk-doc=false")))
-    (inputs (list python-pygobject))
+     `(#:configure-flags '("-Dgtk-doc=false")))
     (native-inputs
      `(("glib:bin" ,glib "bin")
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("gobject-introspection" ,gobject-introspection)))
+    (propagated-inputs (list dbus))
     (synopsis "Control MPRIS-supporting media player applications")
     (description
      "Playerctl is a command-line utility and library for controlling media