[bug#56087] Acknowledgement ([PATCH] gnu: suckless: add farbfeld and propagate input to sent)
Commit Message
From d729f8e2b69a9b36436f6c6d7918ffbe524c5aad Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sat, 18 Jun 2022 17:04:12 +0200
Subject: [PATCH 2/2] gnu: sent: Add farbfeld to propagated-inputs.
* gnu/packages/suckless.scm (sent)[propagated-inputs]: Add it.
---
gnu/packages/suckless.scm | 2 ++
1 file changed, 2 insertions(+)
Comments
Gabriel Wicki schreef op zo 19-06-2022 om 14:36 [+0200]:
> + (propagated-inputs
> + (list farbfeld))
Propagation (*) can be avoided by looking in the source code of 'sent'
to see where farbfeld is started and replacing "farbfeld" by
"/gnu/store/.../bin/farbfeld" (using 'substitute*' & search-input-
file).
(*) Propagation is fragile in some uses (e.g. running directly from the
store) and hence not recommended when it can be avoided.
Greetings,
Maxime.
@@ -532,6 +532,8 @@ (define-public sent
(string-append "LIBS=" (pkg-config "--libs") " -lm")))))
(native-inputs
(list pkg-config))
+ (propagated-inputs
+ (list farbfeld))
(inputs
`(("libpng" ,libpng)
("libx11" ,libx11)