diff mbox series

[bug#56081] gnu: Add cl-sandalphon.compiler-macro.

Message ID 20220619073452.471018-1-paul@apatience.com
State Accepted
Headers show
Series [bug#56081] gnu: Add cl-sandalphon.compiler-macro. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience June 19, 2022, 7:35 a.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-sandalphon.compiler-macro,
  cl-sandalphon.compiler-macro, ecl-sandalphon.compiler-macro): New
  variables.
---
The package is named cl-sandalphon.compiler-macro because that is
the CL package's name.
The ASD system is just compiler-macro, though, which seems confusing
to me.

 gnu/packages/lisp-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

--
2.36.1

Comments

Guillaume Le Vaillant June 20, 2022, 12:04 p.m. UTC | #1
I renamed the package to cl-compiler-macro because we usually take
the main ASDF system name as package name, and I pushed the patch as
a606eea4bc68301fa310290cf6e62f1dfff7e928.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6e4d3c20bc..728502944d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6241,6 +6241,44 @@  (define-public cl-introspect-environment
 (define-public ecl-introspect-environment
   (sbcl-package->ecl-package sbcl-introspect-environment))

+(define-public sbcl-sandalphon.compiler-macro
+  (let ((commit "7796bda64aec5af3ca175170ad3565167868789c")
+        (revision "0"))
+    (package
+      (name "sbcl-sandalphon.compiler-macro")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Bike/compiler-macro")
+               (commit commit)))
+         (file-name (git-file-name "cl-sandalphon.compiler-macro" version))
+         (sha256
+          (base32 "13sswps7s0qy6939mvj8q57hkx0qkga6rl6xjhjr7pk7by0xdsjq"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-systems '("compiler-macro")))
+      (native-inputs
+       (list sbcl-fiveam))
+      (inputs
+       (list sbcl-introspect-environment))
+      (home-page "https://github.com/Bike/compiler-macro")
+      (synopsis "Common Lisp compiler macro utilities")
+      (description "This library is a collection of utilities for writing
+compiler macros.  It is intended to make it possible to make compiler macros
+much more useful, by granting them access to lexical type information, making
+the protocol for declining expansion more convenient, and establishing some
+information for signaling optimization advice to programmers.  Some utilities
+to support this, especially for reasoning on types, are also included.")
+      (license license:cc0))))
+
+(define-public cl-sandalphon.compiler-macro
+  (sbcl-package->cl-source-package sbcl-sandalphon.compiler-macro))
+
+(define-public ecl-sandalphon.compiler-macro
+  (sbcl-package->ecl-package sbcl-sandalphon.compiler-macro))
+
 (define-public sbcl-type-i
   (let ((commit "d34440ab4ebf5a46a58deccb35950b15670e3667")
         (revision "2"))