diff mbox series

[bug#56034] gnu: Add r-amaretto.

Message ID 20220617092929.353-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#56034] gnu: Add r-amaretto. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 17, 2022, 9:29 a.m. UTC
base-commit: ef2d908e22f9d4f4a89782766b67d425935ae4eb

Comments

Ricardo Wurmus June 30, 2022, 1:50 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
> index 1e87b190c2..a78ceb2de5 100644
> --- a/gnu/packages/bioconductor.scm
> +++ b/gnu/packages/bioconductor.scm
> @@ -1987,6 +1987,58 @@ (define-public r-agimicrorna
>  objects are used so that other packages could be used as well.")
>      (license license:gpl3)))
>  
> +(define-public r-amaretto

Applied (with a new commit message).

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..a78ceb2de5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1987,6 +1987,58 @@  (define-public r-agimicrorna
 objects are used so that other packages could be used as well.")
     (license license:gpl3)))
 
+(define-public r-amaretto
+  (package
+    (name "r-amaretto")
+    (version "1.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "AMARETTO" version))
+              (sha256
+               (base32
+                "111dk19b9910icksyr592cvhc5gwvgknr5q4887j9yxbajd7hcmx"))))
+    (properties `((upstream-name . "AMARETTO")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocfilecache
+           r-callr
+           r-circlize
+           r-complexheatmap
+           r-curatedtcgadata
+           r-doparallel
+           r-dplyr
+           r-dt
+           r-foreach
+           r-ggplot2
+           r-glmnet
+           r-gridextra
+           r-httr
+           r-impute
+           r-knitr
+           r-limma
+           r-matrix
+           r-matrixstats
+           r-multiassayexperiment
+           r-rcpp
+           r-readr
+           r-reshape2
+           r-rmarkdown
+           r-tibble))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/AMARETTO")
+    (synopsis "Regulatory network inference and driver gene evaluation")
+    (description
+     "This package @code{AMARETTO} represents an algorithm that integrates copy
+number, DNA methylation and gene expression data to identify a set of driver
+genes by analyzing cancer samples and connects them to clusters of co-expressed
+genes, which we define as modules.  @code{AMARETTO} can be applied in a pancancer
+setting to identify cancer driver genes and their modules on multiple cancer
+sites.  @code{AMARETTO} captures modules enriched in angiogenesis, cell cycle
+and EMT, and modules that accurately predict survival and molecular subtypes.
+This allows @code{AMARETTO} to identify novel cancer driver genes directing
+canonical cancer pathways.")
+    (license license:asl2.0)))
+
 (define-public r-aneufinder
   (package
     (name "r-aneufinder")