diff mbox series

[bug#56027] gnu: Add python-timeout-decorator.

Message ID 20220616185645.10158-1-antero@mailbox.org
State New
Headers show
Series [bug#56027] gnu: Add python-timeout-decorator. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr June 16, 2022, 6:56 p.m. UTC
* gnu/packages/python-xyz.scm (python-timeout-decorator): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Vagrant Cascadian Sept. 2, 2023, 12:23 a.m. UTC | #1
On 2022-06-16, Antero Mejr wrote:
> * gnu/packages/python-xyz.scm (python-timeout-decorator): New variable.
...
> +(define-public python-timeout-decorator
> +  (package
> +    (name "python-timeout-decorator")
> +    (version "0.5.0")

This was added in commit:

b6b09a93fd0d2177e702f43c566bb2b4c2d300c8 gnu: Add python-timeout-decorator.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4b8e63890f..7b67fda45f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -123,6 +123,7 @@ 
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29693,3 +29694,22 @@  (define-public python-langcodes
 and names, built from Unicode CLDR and the IANA subtag registry, if you
 install @code{python-language-data}.")
     (license license:expat)))
+
+(define-public python-timeout-decorator
+  (package
+    (name "python-timeout-decorator")
+    (version "0.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "timeout-decorator" version))
+              (sha256
+               (base32
+                "1mxk2qyydhzncm93z08kvj5ssxq3fr2n7pkrrji28nqwvdc2ybva"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/pnpnpn/timeout-decorator")
+    (synopsis "Python decorator for applying a timeout to a function")
+    (description
+     "This package provides the Python decorator
+@code{timeout_decorator.timeout} which can be used to apply a timeout to the
+decorated function.  The decorator supports multi-threaded applications.")
+    (license license:expat)))