diff mbox series

[bug#56000] gnu: Add python-jsonnet.

Message ID 20220615202213.12173-1-antero@mailbox.org
State New
Headers show
Series [bug#56000] gnu: Add python-jsonnet. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr June 15, 2022, 8:22 p.m. UTC
Tested both public functions, evaluate_file() and evaluate_snippet().

* gnu/packages/cpp.scm (python-jsonnet): New variable.
---
 gnu/packages/cpp.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

Ricardo Wurmus Sept. 2, 2023, 7:17 a.m. UTC | #1
Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 78e4f3bd8e..4ab9f33ae7 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022 Attila Lendvai <attila@lendvai.name>
 ;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1724,6 +1725,16 @@  (define-public jsonnet
 syntax with variables, conditions, functions and more.")
     (license license:asl2.0)))
 
+(define-public python-jsonnet
+  (package
+    (inherit jsonnet)
+    (name "python-jsonnet")
+    (build-system python-build-system)
+    (arguments '())
+    (synopsis "Python bindings for Jsonnet, the data templating language")
+    (description "This package provides a Python library named @code{_jsonnet}
+which can evaluate Jsonnet files and expressions.")))
+
 (define-public simdjson
   (package
     (name "simdjson")