diff mbox series

[bug#55995] gnu: Add cl-policy-cond.

Message ID 20220615120945.349682-1-paul@apatience.com
State Accepted
Headers show
Series [bug#55995] gnu: Add cl-policy-cond. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience June 15, 2022, 12:09 p.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-policy-cond, cl-policy-cond,
ecl-policy-cond): New variables.
---
 gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

--
2.36.1

Comments

Guillaume Le Vaillant June 16, 2022, 12:58 p.m. UTC | #1
Patch pushed as 59ec9e3f3eb60a53cde5b6b90094927e11e62d8a.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c3b14135a3..a0b5c0c8c7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15463,6 +15463,36 @@  (define-public ecl-computable-reals
 (define-public cl-computable-reals
   (sbcl-package->cl-source-package sbcl-computable-reals))

+(define-public sbcl-policy-cond
+  (let ((commit "eedb625520175bfdf44d385ff3b21039b7f75706")
+        (revision "0"))
+    (package
+      (name "sbcl-policy-cond")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/stylewarning/policy-cond")
+               (commit commit)))
+         (file-name (git-file-name "cl-policy-cond" version))
+         (sha256
+          (base32 "0xj2a6lcg7i7g4038sc4f641din6m8vdiha8c5afz9fik80bshxk"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/stylewarning/policy-cond")
+      (synopsis "Insert code based on compiler policy")
+      (description "POLICY-COND provides tools to insert and execute code
+based on a compiler's OPTIMIZE policy. It also contains a contract-like notion
+of expectations, which allow dynamic checking or inclusion of various things
+that should happen depending on compiler policy.")
+      (license license:bsd-3))))
+
+(define-public cl-policy-cond
+  (sbcl-package->cl-source-package sbcl-policy-cond))
+
+(define-public ecl-policy-cond
+  (sbcl-package->ecl-package sbcl-policy-cond))
+
 (define-public sbcl-html-template
   (package
     (name "sbcl-html-template")