diff mbox series

[bug#55896] gnu: Add python-pybare.

Message ID 20220611042737.15082-1-jgart@dismail.de
State New
Headers show
Series [bug#55896] gnu: Add python-pybare. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart June 11, 2022, 4:27 a.m. UTC
* gnu/packages/python-xyz.scm (python-pybare): New variable.
---
 gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

M June 11, 2022, 8:21 a.m. UTC | #1
jgart via Guix-patches via schreef op vr 10-06-2022 om 23:27 [-0500]:
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda _
> +             (chdir "bare")
> +             (invoke "pytest" "."))))))

"./pre-inst-env guix lint python-pybare" will have a warning about
this.  Also, apparently 'list' is considered more readable than
quasiquote/unquote, see [1], so maybe eliminate the quasiquote in
favour of 'list'?

> BARE

Looks like a not well-known acronym, maybe use @acronym?

[1] https://logs.guix.gnu.org/guix/2022-06-09.log#194339

Otherwise the package definition LGTM, but I haven't built or tested it
or read the source code.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4104472848..ceedacd714 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29418,6 +29418,38 @@  (define-public python-gatt
 Currently, Linux is the only platform supported by this library.")
     (license license:expat)))
 
+(define-public python-pybare
+  (package
+    (name "python-pybare")
+    (version "0.1.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+         (git-reference
+          (url "https://git.sr.ht/~chiefnoah/pybare")
+          (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1ibmwwf1rdxlwyxlzhv3v1i0ybsqg0kppim90sm8rsbns86yy4by"))))
+    (build-system python-build-system)
+    (native-inputs
+      (list python-pytest))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (chdir "bare")
+             (invoke "pytest" "."))))))
+    (home-page "https://sr.ht/~chiefnoah/PyBARE/")
+    (synopsis "Declarative implementation of BARE for Python")
+    (description
+"@code{python-pybare} is a general purpose library for strongly
+typed primitives in Python that supports serializing to and from BARE
+messages.")
+    (license license:expat)))
+
 (define-public python-musical-scales
   (package
     (name "python-musical-scales")