diff mbox series

[bug#55851] gnu: Add python-pandarallel.

Message ID 20220608165257.1701-1-wz@freeshell.de
State New
Headers show
Series [bug#55851] gnu: Add python-pandarallel. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny June 8, 2022, 4:52 p.m. UTC
* gnu/packages/python-science.scm (python-pandarallel): New variable.
---
 gnu/packages/python-science.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 0c5299200ffcd16370f047b7ccb187c60f30da34

Comments

Sharlatan Hellseher Feb. 1, 2024, 9:18 p.m. UTC | #1
Hi,

 Modifications applied [7/7]
  - [X] Use git checkout which has tests
  - [X] Swap to pyproject-build-system
  - [X] Fix inputs indention
  - [X] Shorten synopsis
  - [X] Simplify description
  - [X] Run tests in parallel
  - [X] Update to 1.6.5

Pushed as a879dd8b360adcf8f7d69c317dec8cae0f48270c to master.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 855fe9a72c..b16ec5455d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1340,3 +1340,28 @@  (define-public python-gpy
 Python, from the Sheffield machine learning group.  GPy implements a range of
 machine learning algorithms based on GPs.")
     (license license:bsd-3)))
+
+(define-public python-pandarallel
+  (package
+    (name "python-pandarallel")
+    (version "1.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pandarallel" version))
+              (sha256
+               (base32
+                "0fnfwq5j2748lj0fb2qdn4p3h7p0a352bvx6ygwjh5vs0pbicvz3"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-dill python-pandas python-psutil))
+    (native-inputs (list python-mkdocs-material python-numpy python-pytest
+                         python-pytest-cov))
+    (home-page "https://nalepae.github.io/pandarallel/")
+    (synopsis "Simple and efficient tool to parallelize Pandas operations
+across CPUs")
+    (description
+     "With a one line code change, @code{pandarallel} allows any
+Pandas user to take advantage of their multi-core computer, while Pandas uses
+only one core.  @code{pandarallel} also offers nice progress bars (available on
+Notebook and terminal) to get an rough idea of the remaining amount of
+computation to be done.")
+    (license license:bsd-3)))