diff mbox series

[bug#55814,v3,4/8] `python-flake8` now supports `#:tests?`

Message ID 20220607011012.1168112-4-yewscion@gmail.com
State Accepted
Headers show
Series [bug#55814,v3,1/8] Refreshed `python-pycodestyle` to version 2.8.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Rodriguez June 7, 2022, 1:10 a.m. UTC
[Bug: 55814]
---
 gnu/packages/python-xyz.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 48311c6c33..de996826e1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10205,9 +10205,10 @@  (define-public python-flake8
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (replace 'check
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (add-installed-pythonpath inputs outputs)
-                      (invoke "pytest" "-v"))))))
+                    (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+                      (when tests?
+                        (add-installed-pythonpath inputs outputs)
+                        (invoke "pytest" "-v")))))))
     (propagated-inputs (list python-pycodestyle python-entrypoints
                              python-pyflakes python-mccabe))
     (native-inputs (list python-mock python-pytest))