diff mbox series

[bug#55775,v2] gnu: direnv: Update to 2.31.0.

Message ID 20220606031414.13676-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#55775,v2] gnu: direnv: Update to 2.31.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart June 6, 2022, 3:14 a.m. UTC
* gnu/packages/shellutils.scm (direnv): Update to 2.31.0.
[arguments]: Remove trailing boolean in lambda block.

Hi Guixers,

This is direnv not emacs-direnv. Here is version 2 ;()

I forgot the page the lists the debbugs control codes in order to change
the title of this issue.

Should we document that page somewhere for other Guixers using mumi/debbugs?

all best,

jgart

https://whereis.みんな/
---
 gnu/packages/shellutils.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès June 10, 2022, 9:09 p.m. UTC | #1
Hi,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/shellutils.scm (direnv): Update to 2.31.0.
> [arguments]: Remove trailing boolean in lambda block.

Applied, thanks!

> I forgot the page the lists the debbugs control codes in order to change
> the title of this issue.
>
> Should we document that page somewhere for other Guixers using mumi/debbugs?

Yes, it’s at <https://debbugs.gnu.org/server-control.html>.

When using Emacs debbugs.el, one doesn’t have to remember that, which
helps a bit (info "(debbugs-ug) Control Messages").

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index d0f4068062..ad674a3989 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -368,7 +368,7 @@  (define-public trash-cli
 (define-public direnv
   (package
     (name "direnv")
-    (version "2.28.0")
+    (version "2.31.0")
     (source
      (origin (method git-fetch)
              (uri (git-reference
@@ -377,7 +377,7 @@  (define-public direnv
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "0yk53jn7wafklixclka17wyjjs2g5giigjr2bd0xzy10nrzwp7c9"))))
+               "1c52izjzkdhmyrfx1gmbp34n0qpxyxw0s94f0vy3ldlg8xr36wmk"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/direnv/direnv"
@@ -405,8 +405,7 @@  (define-public direnv
                  (invoke "go" "test" "./...")
                  ;; Clean up from the tests, especially so that the extra
                  ;; direnv executable that's generated is removed.
-                 (invoke "make" "clean")))
-             #t)))))
+                 (invoke "make" "clean"))))))))
     (native-inputs
      (list go-github-com-burntsushi-toml go-github-com-direnv-go-dotenv
            go-github-com-mattn-go-isatty go-golang-org-x-mod which))