diff mbox series

[bug#55799] gnu: emacs-dimmer: Update to 0.4.2-1-2f915b1.

Message ID 20220605004725.28988-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#55799] gnu: emacs-dimmer: Update to 0.4.2-1-2f915b1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder June 5, 2022, 12:47 a.m. UTC
To build with Emacs28.

* gnu/packages/emacs-xyz.scm (emacs-dimmer): Update to 0.4.2-1-2f915b1.
---
 gnu/packages/emacs-xyz.scm | 38 ++++++++++++++++++++------------------
 1 file changed, 20 insertions(+), 18 deletions(-)

Comments

Ludovic Courtès June 10, 2022, 9:30 p.m. UTC | #1
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

> To build with Emacs28.
>
> * gnu/packages/emacs-xyz.scm (emacs-dimmer): Update to 0.4.2-1-2f915b1.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4adb1700df..1f377db091 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27844,28 +27844,30 @@  (define-public emacs-elixir-mode
     (license license:gpl3+)))
 
 (define-public emacs-dimmer
-  (package
-    (name "emacs-dimmer")
-    (version "0.4.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/gonewest818/dimmer.el")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0dw0qh5hm1x76s5cqxvylvmjgy0jwy11xm258g6kmx6w1k6r1d2l"))))
-    (build-system emacs-build-system)
-    (home-page "https://github.com/gonewest818/dimmer.el")
-    (synopsis "Visually highlights the selected buffer in Emacs")
-    (description "Dimmer provides a minor mode that indicates which buffer is
+  (let ((commit "2f915b100044e09dd647b22085e1696249c4b115")
+        (revision "1"))
+    (package
+      (name "emacs-dimmer")
+      (version (git-version "0.4.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/gonewest818/dimmer.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "00y6645zjary1sz7517qy5pjwfm5ipsc46sypmdygin65hbbc8wg"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/gonewest818/dimmer.el")
+      (synopsis "Visually highlights the selected buffer in Emacs")
+      (description "Dimmer provides a minor mode that indicates which buffer is
 currently active by dimming the faces in the other buffers.  It does this
 nondestructively, and computes the dimmed faces dynamically such that your
 overall color scheme is shown in a muted form without requiring you to define
 what is a \"dim\" version of every face.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-minibuffer-line
   (package