diff mbox series

[bug#55790,1/1] gnu: browser-extensions: add chromium-web-store

Message ID 20220604082807.18555-1-burning2007@ya.ru
State New
Headers show
Series Add chromium-web-store extension | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Anthony June 4, 2022, 8:28 a.m. UTC
From: Anthony <anthony@example.com>

---
 gnu/packages/browser-extensions.scm | 35 +++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index f305552076..a413da8beb 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -109,3 +109,38 @@  (define ublock-origin
 
 (define-public ublock-origin/chromium
   (make-chromium-extension ublock-origin "chromium"))
+
+(define chromium-web-store
+  (package
+    (name "chromium-web-store")
+    (version "1.4.4.3")
+    (home-page "https://github.com/NeverDecaf/chromium-web-store")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "17jp05dpd8lk8k7fi56jdbhiisx4ajylr6kax01mzfkwfhkd0q9d"))))
+    (build-system copy-build-system)
+    (outputs '("chromium"))
+    (arguments
+      '(#:phases
+        (modify-phases %standard-phases
+          (replace 'install
+            (lambda* (#:key outputs #:allow-other-keys)
+              (copy-recursively "src" (assoc-ref outputs "chromium")))))))
+    (synopsis "Allows adding extensions from chrome web store on ungoogled-chromium")
+    (description "This extension brings the following functionality to
+ungoogled-chromium (and other forks that lack web store support):
+@itemize
+@item Allows installing extensions directly from chrome web store.
+@item Automatically checks for updates to your installed extensions and displays
+them on the badge.
+@end itemize")
+    (license license:expat)))
+
+(define-public chromium-web-store/chromium
+  (make-chromium-extension chromium-web-store "chromium"))