diff mbox series

[bug#55786,2/2] gnu: Add emacs-spaceleader.

Message ID 20220603192135.22923-2-jgart@dismail.de
State Accepted
Headers show
Series [bug#55786,1/2] gnu: Add emacs-bind-map. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart June 3, 2022, 7:21 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-spaceleader): New variable.
---
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

M June 3, 2022, 7:43 p.m. UTC | #1
jgart via Guix-patches via schreef op vr 03-06-2022 om 14:21 [-0500]:
> +      (version (git-version "0.2" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/mohkale/spaceleader")
> +               (commit commit)))

A copy of the GPL is missing, while the GPL requires it:

  4. Conveying Verbatim Copies.

  You may convey verbatim copies of the Program's source code as you
receive it, in any medium, provided that [...]; and give all
recipients a copy of this License along with the Program.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4f35cf8a9c..f8396b199b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30464,6 +30464,36 @@  (define-public emacs-bind-map
 and allows for an arbitrary number of leader keys.")
       (license license:gpl3+))))
 
+(define-public emacs-spaceleader
+  (let ((commit "5e27c7c517f60beaf2bd2446957aec0ce55e11fe")
+        (revision "0"))
+    (package
+      (name "emacs-spaceleader")
+      (version (git-version "0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mohkale/spaceleader")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0ghdybh7rpyrzp02bw43ks009n9idck9sxpjfnbqpyr6j45l5wnh"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+        (list emacs-dash
+              emacs-general
+              emacs-which-key
+              emacs-use-package
+              emacs-bind-map))
+      (home-page "https://github.com/mohkale/spaceleader")
+      (synopsis "Emacs leader-key implementation from Spacemacs")
+      (description
+"@code{emacs-spaceleader} implements the leader-key functionality from
+spacemacs.")
+      (license license:gpl3+))))
+
 (define-public emacs-promise
   (package
     (name "emacs-promise")