diff mbox series

[bug#55786,1/2] gnu: Add emacs-bind-map.

Message ID 20220603192135.22923-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#55786,1/2] gnu: Add emacs-bind-map. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart June 3, 2022, 7:21 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-bind-map): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

M June 3, 2022, 7:41 p.m. UTC | #1
jgart via Guix-patches via schreef op vr 03-06-2022 om 14:21 [-0500]:
> +               (url "https://github.com/justbur/bind-map")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> +           "0crxjy1ykgb429z8ikjv5iy8vg5i0qn8n86p2lgri4glx45sxxx0"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://github.com/mohkale/bind-map")

Both of these result in a 404 for me.
Tobias Geerinckx-Rice June 4, 2022, 9:32 p.m. UTC | #2
Hi,

The GPL was added thanks to jgart[0], so I've pushed both of these 
patches.

Maxime Devos 写道:
> Both of these result in a 404 for me.

https://github.com/justbur/emacs-bind-map (with extra ‘emacs-’) 
works for me.

I changed the base version of emacs-bind-map to 1.1.2 as the 
commit we use postdates [1].

My guess is an incomplete copy-paste job led to both?

…or maybe not, since spaceleader states its version as 0.0.3.  I 
don't see where either 0.2 came from.

I took the liberty of moving both lonely source hash strings up a 
line, because I can :o)

I also re-indented the packages and expanded the description of 
emacs-spaceleader just a bit, based on the .el comment and our own 
emacs-evil-leader package.

Thanks!

T G-R

[0]: https://github.com/mohkale/spaceleader/issues/3
[1]: 
https://github.com/justbur/emacs-bind-map/commit/6977e0fec5c4a3c62a10503798c2a15194167046
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index edcd6a3f4b..4f35cf8a9c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30437,6 +30437,33 @@  (define-public emacs-iter2
 original package.")
     (license license:gpl3+)))
 
+(define-public emacs-bind-map
+  (let ((commit "510a24138d8de3b8df0783f1ac493a551fc9bd74")
+        (revision "0"))
+    (package
+      (name "emacs-bind-map")
+      (version (git-version "0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/justbur/bind-map")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0crxjy1ykgb429z8ikjv5iy8vg5i0qn8n86p2lgri4glx45sxxx0"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/mohkale/bind-map")
+      (synopsis "Bind personal keymaps in multiple locations")
+      (description
+"@code{emacs-bind-map} provides a macro bind-map which can be used to
+make a keymap available across different leader keys including ones
+tied to evil states.  It is essentially a generalization of the idea
+of a leader key as used in Vim or the @code{emacs-evil-leader} package,
+and allows for an arbitrary number of leader keys.")
+      (license license:gpl3+))))
+
 (define-public emacs-promise
   (package
     (name "emacs-promise")