diff mbox series

[bug#55752,3/5] home: services: Add 'lookup-home-service-types' procedure.

Message ID 20220601154302.16222-3-ludo@gnu.org
State Accepted
Headers show
Series Add 'guix system edit' and 'guix home edit' | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ludovic Courtès June 1, 2022, 3:43 p.m. UTC
* gnu/home/services.scm (lookup-home-service-types): New procedure.
* tests/home-services.scm: New file.
* Makefile.am (SCM_TESTS): Add it.
---
 Makefile.am             |  1 +
 gnu/home/services.scm   | 12 +++++++++++
 tests/home-services.scm | 46 +++++++++++++++++++++++++++++++++++++++++
 3 files changed, 59 insertions(+)
 create mode 100644 tests/home-services.scm
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index f585d00b86..89bc03c9a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -497,6 +497,7 @@  SCM_TESTS =					\
   tests/gremlin.scm				\
   tests/hackage.scm				\
   tests/home-import.scm				\
+  tests/home-services.scm			\
   tests/http-client.scm				\
   tests/import-git.scm				\
   tests/import-github.scm			\
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index 8284a4f3fc..5ee3357792 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -33,6 +33,7 @@  (define-module (gnu home services)
   #:use-module (guix modules)
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match)
+  #:use-module (ice-9 vlist)
 
   #:export (home-service-type
             home-profile-service-type
@@ -50,6 +51,7 @@  (define-module (gnu home services)
             xdg-data-files-directory
 
             fold-home-service-types
+            lookup-home-service-types
             home-provenance
 
             %initialize-gettext)
@@ -605,3 +607,13 @@  (define (all-home-service-modules)
 
 (define* (fold-home-service-types proc seed)
   (fold-service-types proc seed (all-home-service-modules)))
+
+(define lookup-home-service-types
+  (let ((table
+         (delay (fold-home-service-types (lambda (type result)
+                                           (vhash-consq (service-type-name type)
+                                                        type result))
+                                         vlist-null))))
+    (lambda (name)
+      "Return the list of services with the given NAME (a symbol)."
+      (vhash-foldq* cons '() name (force table)))))
diff --git a/tests/home-services.scm b/tests/home-services.scm
new file mode 100644
index 0000000000..e13733cabd
--- /dev/null
+++ b/tests/home-services.scm
@@ -0,0 +1,46 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-home-services)
+  #:use-module (gnu services)
+  #:use-module (gnu home services)
+  #:use-module (guix diagnostics)
+  #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-64)
+  #:use-module (ice-9 match))
+
+(test-begin "home-services")
+
+(test-assert "fold-home-service-types"
+  (match (fold-home-service-types cons '())
+    (() #f)
+    (lst (and (every service-type? lst)
+              (every (lambda (type)
+                       (let ((location (service-type-location type)))
+                         (string-contains (location-file location)
+                                          "gnu/home")))
+                     lst)))))
+
+(test-eq "lookup-service-types"
+  home-files-service-type
+  (and (null? (lookup-home-service-types 'does-not-exist-at-all))
+       (match (lookup-home-service-types 'home-files)
+         ((one) one)
+         (x x))))
+
+(test-end)