[bug#55751,4/8] gnu: openjdk12: Make reproducible.
Commit Message
From: Danny Milosavljevic <dannym@scratchpost.org>
* gnu/packages/java.scm (openjdk12)[arguments]<#:phases>[remove-timestamping]:
Modify phase.
---
gnu/packages/java.scm | 5 +++++
1 file changed, 5 insertions(+)
@@ -2138,6 +2138,11 @@ (define-public openjdk12
(substitute-keyword-arguments (package-arguments openjdk11)
((#:phases phases)
`(modify-phases ,phases
+ (replace 'remove-timestamping
+ (lambda _
+ (substitute* "src/hotspot/share/runtime/vm_version.cpp"
+ (("__DATE__") "")
+ (("__TIME__") ""))))
(replace 'fix-java-shebangs
(lambda _
;; This file was "fixed" by patch-source-shebangs, but it requires