diff mbox series

[bug#55730] gnu: Remove python-click@8.

Message ID 20220530182807.10902-1-dom@dominicm.dev
State Accepted
Headers show
Series [bug#55730] gnu: Remove python-click@8. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Dominic Martinez May 30, 2022, 6:28 p.m. UTC
* gnu/packages/python-xyz.scm (python-click-8): Delete variable.
* gnu/packages/python-xyz.scm (python-proselint)[propagated-inputs]: Replace
python-click-8 with python-click.
---
 gnu/packages/python-xyz.scm | 14 +-------------
 1 file changed, 1 insertion(+), 13 deletions(-)

Comments

Dominic Martinez May 30, 2022, 7:04 p.m. UTC | #1
For context, python-click was upgraded to v8.1.2 in 
2b22de8923d2f7a605b51a47013cc77d616547cc, making 'python-click-8' 
irrelevant. Because of the different arguments, proselint would 
have a profile conflict being installed with some other python 
packages like 'python-black'. This removes the unecessary version 
and moves python-proselint to the main python-click package.
Dominic Martinez May 31, 2022, 12:07 a.m. UTC | #2
I missed that Pierre had already made this patch; my bad! Closing.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acd5954fb6..0d8623fbe9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3657,18 +3657,6 @@  (define-public python-click-5
         (base32 "0njsm0wn31l21bi118g5825ma5sa3rwn7v2x4wjd7yiiahkri337"))))
     (arguments `())))
 
-(define-public python-click-8
-  (package (inherit python-click)
-    (name "python-click")
-    (version "8.1.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "click" version))
-       (sha256
-        (base32 "0whs38a2i0561kwbgigs6vic9r0a1887m2v1aw3rmv6r2kz0g5s7"))))
-    (arguments `())))
-
 (define-public python-cligj
   (package
     (name "python-cligj")
@@ -18356,7 +18344,7 @@  (define-public python-proselint
            (lambda _
              (setenv "HOME" "/tmp"))))))
     (propagated-inputs
-     (list python-click-8 python-future python-six))
+     (list python-click python-future python-six))
     (home-page "https://github.com/amperser/proselint")
     (synopsis "Linter for prose")
     (description "@code{python-proselint} is a linter for English prose, that