diff mbox series

[bug#55698] gnu: python-rope: Update to 1.1.1.

Message ID 20220529073643.12834-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#55698] gnu: python-rope: Update to 1.1.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart May 29, 2022, 7:36 a.m. UTC
* gnu/packages/python-xyz.scm (python-rope): Update to 1.1.1.
[arguments]: Disables tests because they depend on python-build.
---
 gnu/packages/python-xyz.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès June 10, 2022, 8:46 p.m. UTC | #1
Hi,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/python-xyz.scm (python-rope): Update to 1.1.1.
> [arguments]: Disables tests because they depend on python-build.

It was updated independently in
e6df9f92f54d6c2be70d014a3a1506d0c4887968.  Closing!

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1125061b3a..39523317f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17093,15 +17093,16 @@  (define-public python2-shedskin
 (define-public python-rope
   (package
     (name "python-rope")
-    (version "0.19.0")
+    (version "1.1.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "rope" version))
        (sha256
         (base32
-         "1nlhkmsfvn2p1msrmwqnypnvr993alzawnpc1605q7rfad3xgrk4"))))
+         "0bkzwkllxxdxd3w70xiy137lqvnlmmaplsc2ya3s23ss4kq8y10k"))))
     (build-system python-build-system)
+    (arguments `(#:tests? #f)) ; https://github.com/python-rope/rope/issues/478
     (home-page "https://github.com/python-rope/rope")
     (synopsis "Refactoring library for Python")
     (description "Rope is a refactoring library for Python.  It facilitates