diff mbox series

[bug#55656] gnu: perl-http-daemon: Update to 6.14.

Message ID 20220526130335.27626-1-attila@lendvai.name
State New
Headers show
Series [bug#55656] gnu: perl-http-daemon: Update to 6.14. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai May 26, 2022, 1:03 p.m. UTC
---
 gnu/packages/web.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Christopher Baines May 27, 2022, 10:03 a.m. UTC | #1
Attila Lendvai <attila@lendvai.name> writes:

> ---
>  gnu/packages/web.scm | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index ffcb709e82..0186ac06e5 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -3462,18 +3462,19 @@ (define-public perl-http-cookies
>  (define-public perl-http-daemon
>    (package
>      (name "perl-http-daemon")
> -    (version "6.01")
> +    (version "6.14")
>      (source (origin
>               (method url-fetch)
>               (uri (string-append
> -                   "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Daemon-"
> +                   "mirror://cpan/authors/id/O/OA/OALDERS/HTTP-Daemon-"
>                     version ".tar.gz"))
>               (sha256
>                (base32
> -               "1hmd2isrkilf0q0nkxms1q64kikjmcw9imbvrjgky6kh89vqdza3"))))
> +               "079fkcq2vdrzdf0bml52kz73n9gdv1xg0qf72c9v505v7izpwxph"))))
>      (build-system perl-build-system)
>      (propagated-inputs
> -     (list perl-http-message perl-lwp-mediatypes))
> +     (list perl-http-message perl-lwp-mediatypes perl-module-build-tiny
> +           perl-test-needs))
>      (license license:perl-license)
>      (synopsis "Perl simple http server class")
>      (description

This looks good to me, but because this is an input to wget, which seems
to have a lot of dependent packages (~900), this probably needs to go to
the staging branch.

Unfortunately, staging is frozen at the moment, so I'm not sure if it's
the right time to push it.
Vagrant Cascadian Sept. 2, 2023, 12:08 a.m. UTC | #2
retitle 55656 gnu: Add perl-http-daemon-ssl
thanks

On 2022-05-26, Attila Lendvai wrote:
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index ffcb709e82..0186ac06e5 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -3462,18 +3462,19 @@ (define-public perl-http-cookies
>  (define-public perl-http-daemon
>    (package
>      (name "perl-http-daemon")
> -    (version "6.01")
> +    (version "6.14")

perl-http-daemon was updated in:

80d84f76cdcf8115ef6f659353131ce1dce58cc4 gnu: perl-http-daemon: Update to 6.14.
c888e9028db76e52a7f2fccef84d68a7e3564837 gnu: perl-http-daemon: Update to 6.14.

The remaining issue is "gnu: Add perl-http-daemon-ssl." so retitling
appropriately.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ffcb709e82..0186ac06e5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3462,18 +3462,19 @@  (define-public perl-http-cookies
 (define-public perl-http-daemon
   (package
     (name "perl-http-daemon")
-    (version "6.01")
+    (version "6.14")
     (source (origin
              (method url-fetch)
              (uri (string-append
-                   "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Daemon-"
+                   "mirror://cpan/authors/id/O/OA/OALDERS/HTTP-Daemon-"
                    version ".tar.gz"))
              (sha256
               (base32
-               "1hmd2isrkilf0q0nkxms1q64kikjmcw9imbvrjgky6kh89vqdza3"))))
+               "079fkcq2vdrzdf0bml52kz73n9gdv1xg0qf72c9v505v7izpwxph"))))
     (build-system perl-build-system)
     (propagated-inputs
-     (list perl-http-message perl-lwp-mediatypes))
+     (list perl-http-message perl-lwp-mediatypes perl-module-build-tiny
+           perl-test-needs))
     (license license:perl-license)
     (synopsis "Perl simple http server class")
     (description