diff mbox series

[bug#55615] gnu: Add r-pscbs.

Message ID 20220524180850.3381234-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#55615] gnu: Add r-pscbs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier May 24, 2022, 6:08 p.m. UTC
* gnu/packages/bioconductor.scm (r-pscbs): New variable.
---
 gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)


base-commit: 01793ed03e8aa0960bff7adc21fd270e1527e68e

Comments

Ricardo Wurmus May 24, 2022, 9:29 p.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> writes:

> * gnu/packages/bioconductor.scm (r-pscbs): New variable.

Applied with formatting changes.  Thanks!
Simon Tournier May 25, 2022, 7:31 a.m. UTC | #2
Hi,

On Tue, 24 May 2022 at 23:30, Ricardo Wurmus <rekado@elephly.net> wrote:

> Applied with formatting changes.  Thanks!

Indeed, sorry.  I reformatted the output of "guix import" but then I
forgot to reformat again the phase modification (my bad!).  And I ran
"guix lint" which reported nothing.   But "guix style" reformats;
which I do not use (yet).

Well, it is many manual error-prone steps.  My questions are :

 1. Could we adapted "guix import cran" to output something using the
format of "guix style"?
 2. Could we add a checker in "guix lint" using "guix style" and warn?


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 80cf28c954..7fed1aa18b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4560,6 +4560,48 @@  (define-public r-pcamethods
 structure (pcaRes) to provide a common interface to the PCA results.")
     (license license:gpl3+)))
 
+;; This is a CRAN package, but it depends on a Bioconductor package:
+;; r-aroma-light, r-dnacopy..
+(define-public r-pscbs
+  (package
+    (name "r-pscbs")
+    (version "0.66.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "PSCBS" version))
+       (sha256
+        (base32 "14rs2wywipbkia3dbzfhpnkmfgdvm2bf586lggsx63sywlv5d02q"))))
+    (properties `((upstream-name . "PSCBS")))
+    (build-system r-build-system)
+    (arguments
+     `(#:phases
+      (modify-phases %standard-phases
+          (add-before 'install 'change-home-dir
+            (lambda _
+              ;; Change from /homeless-shelter to /tmp for write permission.
+              (setenv "HOME" "/tmp"))))))
+    (propagated-inputs
+     (list r-aroma-light
+           r-dnacopy
+           r-future
+           r-listenv
+           r-matrixstats
+           r-r-cache
+           r-r-methodss3
+           r-r-oo
+           r-r-utils))
+    (native-inputs
+     (list r-r-rsp       ;used to build vignettes
+           r-r-devices))
+    (home-page "https://github.com/HenrikBengtsson/PSCBS")
+    (synopsis "Analysis of Parent-Specific DNA Copy Numbers")
+    (description
+     "Segmentation of allele-specific DNA copy number data and detection of
+regions with abnormal copy number within each parental chromosome.  Both
+tumor-normal paired and tumor-only analyses are supported.")
+    (license license:gpl2+)))
+
 (define-public r-protgenerics
   (package
     (name "r-protgenerics")